zookeeper-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andor Molnar <an...@cloudera.com.INVALID>
Subject Re: Recent ZK Jenkins failures due to SSL protocol changes on central
Date Fri, 22 Jun 2018 10:16:55 GMT
+1, drop JDK 1.6 support

Andor



On Fri, Jun 22, 2018 at 5:53 AM, Michael Han <hanm@apache.org> wrote:

> +1 on dropping JDK 1.6 support for branch-3.4.
>
> On Thu, Jun 21, 2018 at 3:55 PM, Brian Nixon <brian.nixon.cs@gmail.com>
> wrote:
>
> > +1 for discontinuing support for jdk1.6
> >
> >
> > On Thu, Jun 21, 2018 at 7:58 AM, Norbert Kalmar <
> > nkalmar@cloudera.com.invalid> wrote:
> >
> > > Hi Patrick,
> > >
> > > In my opinion terminating support for java 1.6 is a good idea. Even
> it's
> > > extended support will end this year (
> > > http://www.oracle.com/technetwork/java/javase/eol-135779.html).
> > > And the projects I've seen are all updated from java 6 by now,
> especially
> > > as more and more libraries and components are discontinuing support for
> > 1.6
> > > (WebSphere, just to name one).
> > >
> > > Regards,
> > > Norbert
> > >
> > > On Thu, Jun 21, 2018 at 4:30 PM Patrick Hunt <phunt@apache.org> wrote:
> > >
> > > > FYI - I believe we're seeing:
> > > >
> > > > https://blog.sonatype.com/enhancing-ssl-security-and-
> > > http/2-support-for-central
> > > >
> > > > ------------
> > > > ivy-download:
> > > >       [get] Getting:
> > > > https://repo1.maven.org/maven2/org/apache/ivy/ivy/2.4.
> 0/ivy-2.4.0.jar
> > > >       [get] To:
> > > >
> > > > /home/jenkins/jenkins-slave/workspace/ZooKeeper_branch34/
> > > src/java/lib/ivy-2.4.0.jar
> > > >       [get] Error getting
> > > > https://repo1.maven.org/maven2/org/apache/ivy/ivy/2.4.
> 0/ivy-2.4.0.jar
> > to
> > > >
> > > > /home/jenkins/jenkins-slave/workspace/ZooKeeper_branch34/
> > > src/java/lib/ivy-2.4.0.jar
> > > >
> > > > BUILD FAILED
> > > > /home/jenkins/jenkins-slave/workspace/ZooKeeper_branch34/
> > build.xml:392:
> > > > javax.net.ssl.SSLException: Received fatal alert: protocol_version
> > > > -----------------
> > > >
> > > > It looks like we are ok with jdk 1.8+, and can mitigate 1.7, however
> > 1.6
> > > > and earlier jdks have no option (aside turning off https usage which
> > > > doesn't appeal to me).
> > > >
> > > > I can update the jenkins 1.7 based jobs. Thoughts on 1.6 and earlier?
> > > > Perhaps we should use this as an opportunity to explicitly/officially
> > > > discontinue support in the next version?
> > > >
> > > > http://zookeeper.apache.org/doc/r3.4.12/zookeeperAdmin.
> > > html#sc_requiredSoftware
> > > >
> > > > Patrick
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message