zookeeper-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matteo Merli <mme...@apache.org>
Subject Re: ZooKeeper 3.4 to 3.5.x upgrade: "No snapshot found, but there are log entries. Something is broken!"
Date Tue, 05 Jun 2018 05:02:13 GMT
> >> Also can you advice the steps for people who using 3.4.x to upgrade to
> 3.5.4-beta
>
> The only catch I remember is that if you are using a version older than
> 3.4.6, you'd need to upgrade through 3.4.6 first before upgrading to 3.5.x,
> if you are doing a rolling upgrade and want to keep the liveness of the
> quorum. See more
> https://zookeeper.apache.org/doc/r3.5.3-beta/zookeeperReconfig.html#ch_reconfig_upgrade
> .
>


Hi Michael,

This is happening upgrading from 3.4.10 to 3.5.4. It's single node embedded
ZK server, part of a self-contained standalone service.

Definitely , in 3.4.10 single mode, the snapshot dosesn't get created on
bootstrap.

Thanks,
Matteo
-- 
Matteo Merli
<mmerli@apache.org>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message