zookeeper-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ZOOKEEPER-910) Use SelectionKey.isXYZ() methods instead of complicated binary logic
Date Thu, 10 May 2018 20:46:00 GMT

    [ https://issues.apache.org/jira/browse/ZOOKEEPER-910?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16471084#comment-16471084
] 

Hadoop QA commented on ZOOKEEPER-910:
-------------------------------------

-1 overall.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12642014/ZOOKEEPER-910.patch
  against trunk revision 2fa315b7d0ed65828479fcdcc9e76ca8552fba4a.

    +1 @author.  The patch does not contain any @author tags.

    -1 tests included.  The patch doesn't appear to include any new or modified tests.
                        Please justify why no new tests are needed for this patch.
                        Also please list what manual steps were performed to verify this patch.

    -1 patch.  The patch command could not apply the patch.

Console output: https://builds.apache.org/job/PreCommit-ZOOKEEPER-Build/3683//console

This message is automatically generated.

> Use SelectionKey.isXYZ() methods instead of complicated binary logic
> --------------------------------------------------------------------
>
>                 Key: ZOOKEEPER-910
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-910
>             Project: ZooKeeper
>          Issue Type: Sub-task
>          Components: server
>            Reporter: Thomas Koch
>            Assignee: Michi Mutsuzaki
>            Priority: Minor
>             Fix For: 3.6.0, 3.5.5
>
>         Attachments: ZOOKEEPER-910.patch
>
>
> The SelectionKey class provides methods to replace something like this
> (k.readyOps() & (SelectionKey.OP_READ | SelectionKey.OP_WRITE)) != 0
> with
> selectionKey.isReadable() || selectionKey.isWritable()
> It may be possible, that the first version saves a CPU cycle or two, but the later version
saves developer brain cycles which are much more expensive.
> I suppose that there are many more places in the server code where this replacement could
be done. I propose that whoever touches a code line like this should make the replacement.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message