zookeeper-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From phunt <...@git.apache.org>
Subject [GitHub] zookeeper issue #528: ZOOKEEPER-3034 Facing issues while building from sourc...
Date Thu, 31 May 2018 20:56:26 GMT
Github user phunt commented on the issue:

    https://github.com/apache/zookeeper/pull/528
  
    Hm. It's not very clear that
    
    > ./configure: line 5034: PKG_PROG_PKG_CONFIG: command not found
    
    means that pkg-config needs to be installed. Esp given we've never needed it - it's a
new dependency.
    
    Here's an example of some pushback in the curl community https://github.com/curl/curl/issues/972
    
    If you do want to add this you probably need to add something like:
    
    ```
    m4_ifndef([PKG_PROG_PKG_CONFIG],
      [m4_fatal([Could not locate the pkg-config autoconf macros.
    Please make sure pkg-config is installed and, if necessary, set the environment
    variable ACLOCAL="aclocal -I/path/to/pkg.m4".])])
    ```
    
    although I'm honestly not very psyched about this change. It's going to break a bunch
of folk's builds.



---

Mime
View raw message