zookeeper-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ZOOKEEPER-3000) Use error-prone compiler
Date Sun, 22 Apr 2018 17:04:00 GMT

    [ https://issues.apache.org/jira/browse/ZOOKEEPER-3000?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16447286#comment-16447286
] 

ASF GitHub Bot commented on ZOOKEEPER-3000:
-------------------------------------------

Github user leventov commented on the issue:

    https://github.com/apache/zookeeper/pull/490
  
    Yes, Java 8 is required for the build, but the produced bytecode could target Java 6 or
7. Here is a citation from http://errorprone.info/docs/installation: 
    
    > Our goal is to make it simple to add Error Prone checks to your existing Java compilation.
Please note that Error Prone must be run on JDK 8 or newer. It can be used to build Java 6
or 7 code by setting the appropriate -source / -target / -bootclasspath flags.


> Use error-prone compiler
> ------------------------
>
>                 Key: ZOOKEEPER-3000
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-3000
>             Project: ZooKeeper
>          Issue Type: Improvement
>            Reporter: Roman Leventov
>            Priority: Major
>
> See http://errorprone.info/



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message