zookeeper-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ZOOKEEPER-2415) SessionTest is using Thread deprecated API.
Date Mon, 23 Apr 2018 22:48:00 GMT

    [ https://issues.apache.org/jira/browse/ZOOKEEPER-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16448991#comment-16448991
] 

ASF GitHub Bot commented on ZOOKEEPER-2415:
-------------------------------------------

Github user phunt commented on the issue:

    https://github.com/apache/zookeeper/pull/497
  
    +1. Looks reasonable however:
    
    1) this problem also exists in src/java/test/org/apache/zookeeper/test/ReadOnlyModeTest.java
- do you want to fix it as part of this change or handle as a separate jira? (either way is
fine with me - separate might make it simpler to review/commit and make progress tbh, but
up to you)
    
    2) regardless 1) above, this doesn't apply to branch-3.4 - the original jira says it affects
3.4, I'm assuming we want to fix there as well? Could you create a separate PR for this? I'd
like to commit both at the same time.


> SessionTest is using Thread deprecated API.
> -------------------------------------------
>
>                 Key: ZOOKEEPER-2415
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-2415
>             Project: ZooKeeper
>          Issue Type: Test
>          Components: tests
>    Affects Versions: 3.4.8, 3.5.1, 3.6.0
>            Reporter: Flavio Junqueira
>            Assignee: Andor Molnar
>            Priority: Major
>             Fix For: 3.5.4, 3.6.0, 3.4.13
>
>
> The test class is using calls such as {{Thread.suspend}} and {{Thread.resume}}.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message