zookeeper-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From phunt <...@git.apache.org>
Subject [GitHub] zookeeper issue #490: ZOOKEEPER-3000: Use error-prone compiler
Date Mon, 23 Apr 2018 23:58:53 GMT
Github user phunt commented on the issue:

    https://github.com/apache/zookeeper/pull/490
  
    This is a good addition, thanks for bringing to our attention @leventov .
    
    Unfortunately however we can't replace the std javac compiler with error_prone in the
toolchain outright - we can have a separate option/target to do this, but it can't be the
default. 
    
    I would recommend separating this into two jiras/pullrequests - one to change the build,
the other to address the found issues.
    
    @leventov you mentioned "I'm not proficient in Ant" - perhaps one of the other folks could
help with this? @anmolnar you mentioned hbase is using it - anything we can pull from there
wrt how they integrate it into their build?
    
    ps. I like the idea of also getting this into 3.4 branch as well, which means it needs
to be optional so that the user can run it when they have java8+, but otw not. Which matches
my intent/statement above.
    
    pps. looks like there is a new version of error_prone, might want to take this opportunity
to update the dependency version. I notice the library is ASL2.0 which is also good (license
is in the COPYING file currently)


---

Mime
View raw message