zookeeper-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From leventov <...@git.apache.org>
Subject [GitHub] zookeeper issue #490: ZOOKEEPER-3000: Use error-prone compiler
Date Sun, 22 Apr 2018 17:10:43 GMT
Github user leventov commented on the issue:

    https://github.com/apache/zookeeper/pull/490
  
    @anmolnar if you try to run `ant test` while the test are not compiled yet (i. e. they
have to be compiled), and Ant uses Java 7 which is installed on your machine for compilation,
yes, this is expected that it will fail. You would need to run with Java 8.
    
    However, I see that `javac.source` and `javac.target` in `build.xml` already set to 1.8,
how do you test it with Java 7 anyway?


---

Mime
View raw message