zookeeper-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From leventov <...@git.apache.org>
Subject [GitHub] zookeeper issue #490: ZOOKEEPER-3000: Use error-prone compiler
Date Sun, 22 Apr 2018 17:03:20 GMT
Github user leventov commented on the issue:

    https://github.com/apache/zookeeper/pull/490
  
    Yes, Java 8 is required for the build, but the produced bytecode could target Java 6 or
7. Here is a citation from http://errorprone.info/docs/installation: 
    
    > Our goal is to make it simple to add Error Prone checks to your existing Java compilation.
Please note that Error Prone must be run on JDK 8 or newer. It can be used to build Java 6
or 7 code by setting the appropriate -source / -target / -bootclasspath flags.


---

Mime
View raw message