zookeeper-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From anmolnar <...@git.apache.org>
Subject [GitHub] zookeeper issue #490: ZOOKEEPER-3000: Use error-prone compiler
Date Mon, 26 Mar 2018 09:30:11 GMT
Github user anmolnar commented on the issue:

    https://github.com/apache/zookeeper/pull/490
  
    @leventov I've just verified your patch on my local machine.
    
    Is Java8 a requirement for error-prone to work?
    Because running `ant clean test` with java7 I got the following error message:
    > BUILD FAILED
    /Users/andor/git/my-zookeeper/build.xml:1417: The following error occurred while executing
this line:
    /Users/andor/git/my-zookeeper/build.xml:490: Class com.google.errorprone.ErrorProneAntCompilerAdapter
could not be loaded because of an invalid dependency.
    
    If that's the case, I'm afraid we can only merge this patch to master, once we upgraded
to java8 which is coming soon, but not there yet.
    
    Additionally running with Java8 I got 75 warning messages. Is that accurate?


---

Mime
View raw message