zookeeper-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ZOOKEEPER-2952) Upgrade third party libraries to address vulnerabilities
Date Tue, 12 Dec 2017 12:36:00 GMT

    [ https://issues.apache.org/jira/browse/ZOOKEEPER-2952?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16287535#comment-16287535
] 

ASF GitHub Bot commented on ZOOKEEPER-2952:
-------------------------------------------

GitHub user anmolnar opened a pull request:

    https://github.com/apache/zookeeper/pull/429

    ZOOKEEPER-2952. Upgrade third party libs: netty, slf4j

    

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/anmolnar/zookeeper ZOOKEEPER-2952

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/zookeeper/pull/429.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #429
    
----
commit 949ada4ae0ad87388269bcc728affffcce325f04
Author: Andor Molnar <andor@cloudera.com>
Date:   2017-12-12T11:04:48Z

    ZOOKEEPER-2952. Upgrade third party libs: netty, slf4j

----


> Upgrade third party libraries to address vulnerabilities
> --------------------------------------------------------
>
>                 Key: ZOOKEEPER-2952
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-2952
>             Project: ZooKeeper
>          Issue Type: Improvement
>          Components: server
>    Affects Versions: 3.5.3, 3.4.11
>            Reporter: Andor Molnar
>            Assignee: Andor Molnar
>            Priority: Critical
>              Labels: dependencies, upgrade, vulnerabilities
>             Fix For: 3.5.4, 3.4.12
>
>
> Hi,
> I'm going to upgrade the following third party libraries in order to address vulnerabilities
found in them:
> - io.netty:netty 3.10.5.Final -> 3.10.6.Final (CVE-2015-2156 (H), CVE-2014-3488 (H),
protobuf: CVE-2015-5237 (H), npn-api: CVE-2017-9735 (H), CVE-1999-1198 (H), CVE-1999-1193
(H))
> - org.slf4j:slf4j-api 1.7.5 -> 1.7.25
> Please review the list and let me know if you have any concerns or would like to add
more deps to upgrade.
> Thanks,
> Andor



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message