zookeeper-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andor Molnar <an...@cloudera.com>
Subject Re: Apache build failing with test-core-cppunit
Date Tue, 21 Nov 2017 18:32:37 GMT
I checked back a few failing builds and see different hosts failing: H4,
H9, H12, ...





On Tue, Nov 21, 2017 at 6:26 PM, Patrick Hunt <phunt@apache.org> wrote:

> Could it be an environment issue? I see the following just before the
> failure:
>
>      [exec] rm: cannot remove '/tmp/zkdata/myid': Permission denied
>
> check whether it's happening on just one host (jenkins).
>
> Patrick
>
> On Tue, Nov 21, 2017 at 6:25 AM, Andor Molnar <andor@cloudera.com> wrote:
>
> > Looks like only https://builds.apache.org/job/ZooKeeper-trunk is
> affected.
> >
> >
> > On Tue, Nov 21, 2017 at 3:22 PM, Andor Molnar <andor@cloudera.com>
> wrote:
> >
> > > Hi,
> > >
> > > Zookeeper build has been failing for a while with some weird error in
> > > test-core-cppunit task. In most cases the error is the following:
> > >
> > > ...
> > >      [exec] Zookeeper_simpleSystem::testGetChildren2 : elapsed 1052 :
> OK
> > >      [exec] Zookeeper_simpleSystem::testLastZxid : elapsed 4520 : OK
> > >      [exec] Zookeeper_simpleSystem::testRemoveWatchers ZooKeeper
> server
> > > started : elapsed 5390 : OK
> > >      [exec] rm: cannot remove '/tmp/zkdata/myid': Permission denied
> > >      [exec] Zookeeper_readOnly::testReadOnly : assertion : elapsed
> 4018
> > >      [exec] /home/jenkins/jenkins-slave/workspace/ZooKeeper-trunk/src/
> > > c/tests/TestReadOnlyClient.cc:99: Assertion: equality assertion failed
> > > [Expected: 0, Actual  : -4]
> > >      [exec] Failures !!!
> > >      [exec] Run: 74   Failure total: 1   Failures: 1   Errors: 0
> > >      [exec] FAIL: zktest-mt
> > >      [exec] ==========================================
> > >      [exec] 1 of 2 tests failed
> > >      [exec] Please report to user@zookeeper.apache.org
> > >      [exec] ==========================================
> > >      [exec] Makefile:1744: recipe for target 'check-TESTS' failed
> > >      [exec] make[1]: Leaving directory '/home/jenkins/jenkins-slave/
> > > workspace/ZooKeeper-trunk/build/test/test-cppunit'
> > >      [exec] Makefile:2000: recipe for target 'check-am' failed
> > >      [exec] /home/jenkins/jenkins-slave/workspace/ZooKeeper-trunk/src/
> > c/tests/zkServer.sh:
> > > line 62: kill: (10156) - No such process
> > >      [exec] make[1]: *** [check-TESTS] Error 1
> > >      [exec] make: *** [check-am] Error 2
> > >
> > > ----------------------
> > >
> > > Test at line TestReadOnlyClient.cc:99 got ConnectionLoss event.
> > > Does anyone has a clue what could be the root cause of this?
> > >
> > > Regards,
> > > Andor
> > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message