zookeeper-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karl Wright (JIRA)" <j...@apache.org>
Subject [jira] [Created] (ZOOKEEPER-2889) Zookeeper standalone instance startup references logging classes incompatible with log4j-1.2-api
Date Sat, 02 Sep 2017 08:59:00 GMT
Karl Wright created ZOOKEEPER-2889:
--------------------------------------

             Summary: Zookeeper standalone instance startup references logging classes incompatible
with log4j-1.2-api
                 Key: ZOOKEEPER-2889
                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-2889
             Project: ZooKeeper
          Issue Type: Bug
    Affects Versions: 3.4.8
            Reporter: Karl Wright


Starting Zookeeper in the following way causes "ClassNotFoundException" errors, and aborts,
in a log4j 2.x environment:

{code}
"%JAVA_HOME%\bin\java" %JAVAOPTIONS% org.apache.zookeeper.server.quorum.QuorumPeerMain zookeeper.cfg
{code}

The log4j 2.x jars in the classpath are:

{code}
log4j-1.2-api
log4j-core
log4j-api
{code}

It appears that the Zookeeper QuorumPeerMain class is incompatible with the limited log4j
1.2 API that log4j 2.x includes.  Zookeeper 3.4.8 works fine with log4j 2.x except when you
start it as a service in this way.





--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message