zookeeper-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ZOOKEEPER-2859) CMake build doesn't support OS X
Date Sun, 30 Jul 2017 19:33:02 GMT

    [ https://issues.apache.org/jira/browse/ZOOKEEPER-2859?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16106622#comment-16106622
] 

ASF GitHub Bot commented on ZOOKEEPER-2859:
-------------------------------------------

Github user andschwa commented on the issue:

    https://github.com/apache/zookeeper/pull/319
  
    Also, I'd like to test `Autotools` on OS X, because I believe it has the same problem
(unconditionally adds `libm` and `librt`), but I can't get past `autoconf -if` since I don't
have `cppunit.m4`. I'm looking high and low for it: it's not in `/usr/local/` nor `/opt`,
the brew CppUnit didn't come with it, and none of the Autotools directories has it. I found
[ZOOKEEPER-1454](https://issues.apache.org/jira/browse/ZOOKEEPER-1454), and it showed me how
to specify where `cppunit.m4` is, but that's not much use if I don't have it.
    
    Do you know, does anyone have this building on OS X?


> CMake build doesn't support OS X
> --------------------------------
>
>                 Key: ZOOKEEPER-2859
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-2859
>             Project: ZooKeeper
>          Issue Type: Bug
>         Environment: OS X 10.12.6
>            Reporter: Andrew Schwartzmeyer
>            Assignee: Andrew Schwartzmeyer
>
> Couple problems:
> libm, librt, and libdl are all Linux specific, and provided "for free" on OS X
> CppUnit (at least on OS X) needs `-std=c++11`
> clang's ld doesn't understand --wrap
> I can post an easy patch that at least lets you build the client (but not the tests).
The tests use that `--wrap` and it's non trivial to fix that on OS X.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message