zookeeper-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ZOOKEEPER-2859) CMake build doesn't support OS X
Date Sun, 30 Jul 2017 16:40:00 GMT

    [ https://issues.apache.org/jira/browse/ZOOKEEPER-2859?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16106550#comment-16106550
] 

ASF GitHub Bot commented on ZOOKEEPER-2859:
-------------------------------------------

Github user hanm commented on the issue:

    https://github.com/apache/zookeeper/pull/319
  
    Any idea why precommit job generates java doc warnings? Seems not related to the patch.


> CMake build doesn't support OS X
> --------------------------------
>
>                 Key: ZOOKEEPER-2859
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-2859
>             Project: ZooKeeper
>          Issue Type: Bug
>         Environment: OS X 10.12.6
>            Reporter: Andrew Schwartzmeyer
>            Assignee: Andrew Schwartzmeyer
>
> Couple problems:
> libm, librt, and libdl are all Linux specific, and provided "for free" on OS X
> CppUnit (at least on OS X) needs `-std=c++11`
> clang's ld doesn't understand --wrap
> I can post an easy patch that at least lets you build the client (but not the tests).
The tests use that `--wrap` and it's non trivial to fix that on OS X.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message