zookeeper-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "JiangJiafu (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ZOOKEEPER-2800) zookeeper ephemeral node not deleted after server restart and consistency is not hold
Date Fri, 09 Jun 2017 07:37:18 GMT

    [ https://issues.apache.org/jira/browse/ZOOKEEPER-2800?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16044091#comment-16044091
] 

JiangJiafu commented on ZOOKEEPER-2800:
---------------------------------------

I found that, the first time the follower try to reconnect to the leader, it sends the peerLastZxid
0x100003748 to the leader and begin to sync the log from 0x100003749, but failed due to network
disconnection. The second time the follower try to reconnect to the leader, it sends the peerLastZxid
0x10000385c to the leader, therefore, the log 0x100003749 ~ 0x10000385c is missing!!



> zookeeper ephemeral node not deleted after server restart and consistency is not hold
> -------------------------------------------------------------------------------------
>
>                 Key: ZOOKEEPER-2800
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-2800
>             Project: ZooKeeper
>          Issue Type: Bug
>          Components: quorum
>    Affects Versions: 3.4.11
>         Environment: Centos6.5 java8
>            Reporter: JiangJiafu
>            Priority: Critical
>         Attachments: zoo.cfg, zookeeper2.out, zookeeper3.out, zookeeper.out
>
>
> I deploy a cluster of ZooKeeper with three nodes:
> ofs_zk1:30.0.0.72
> ofs_zk2:30.0.0.73
> ofs_zk3:30.0.0.99
> On 2017-06-02, use the c zk client to create some ephemeral sequential nodes,:
> /adm_election/rolemgr/rolemgr0000000008,
> /adm_election/rolemgr/rolemgr0000000011,
> /adm_election/rolemgr/rolemgr0000000012,
> with sesstion timeout 20000 ms.
> Then  I restart ofs_zk1 and ofs_zk2.
> On 2017-06-05, I found that, these ephemeral  nodes still exist on ofs_zk1.
> I can check the nodes by zkCli.sh get command on ofs_zk1.
> But these nodes doesn't not exist on ofs_zk2 and ofs_zk3.
> Is it odd?
> I have upload the whole deploy directory of three nodes to:
> https://pan.baidu.com/s/1miohiCo ,
> The log is printed in log/zookeeper.out
> log of ofs_zk3 is too large, so I only show the head 1000 lines.
> Since I find this PR a little late, some snapshot and log may be deleted.
> I hope anyone can help find the reason.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message