zookeeper-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From upendar devu <devulapal...@gmail.com>
Subject Re: What is the role of Zookeeper and its external Integration dependencies
Date Thu, 13 Apr 2017 18:46:12 GMT
Sorry looks like I missed to share my queries to dev team

We are using zookeeper 3.4.6 version with integration of Apache Kafka ,
Apache Storm and Zookeeper.

I would like to understand the following things. Please help me to clarify.

1. What are Integration dependencies of Zookeeper ?
   Since we are using Kafka, Storm , so we need Zookeeper ? which external
integration has dependencies

2. What is the actual role of zookeeper with the integration of Apache
Kafka,Apache Storm.   Could you please provide a better use case to
understand. sorry asking this question, I need to understand and am aware
of this at least now from you.

3. We are planning to upgrade Zookeeper version to 3.4.10 due to CVE (
CVE-2016-5017) mentioned with version 3.4.6 ;  Do we also need to upgrade
depedency integration components like Apache Storm(*using 0.10.0*) and
Apache Kafka (Using *0.8.1.1*) ? which version those should be upgraded to
 ?

On Thu, Apr 13, 2017 at 2:43 PM, upendar devu <devulapalli8@gmail.com>
wrote:

> Including Dev Team to address my queries
>
> On Thu, Apr 13, 2017 at 2:39 PM, upendar devu <devulapalli8@gmail.com>
> wrote:
>
>> We are using zookeeper 3.4.6 version with integration of Apache Kafka ,
>> Apache Storm and Zookeeper.
>>
>> I would like to understand the following things. Please help me to
>> clarify.
>>
>> 1. What are Integration dependencies of Zookeeper ?
>>    Since we are using Kafka, Storm , so we need Zookeeper ? which
>> external integration has dependencies
>>
>> 2. What is the actual role of zookeeper with the integration of Apache
>> Kafka,Apache Storm.   Could you please provide a better use case to
>> understand.
>>
>> 3. We are planning to upgrade Zookeeper version to 3.4.10 due to CVE (
>> CVE-2016-5017) mentioned with version 3.4.6 ;  Do we also need to
>> upgrade depedency integration components like Apache Storm(*using 0.10.0*)
>> and Apache Kafka (Using *0.8.1.1*) ? which version those should be
>> upgraded to  ?
>>
>>
>> Thanks
>> Upendar
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message