zookeeper-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ZOOKEEPER-2696) Eclipse ant ask no longer determines correct classpath for tests after ZOOKEEPER-2689
Date Wed, 15 Feb 2017 22:40:41 GMT

    [ https://issues.apache.org/jira/browse/ZOOKEEPER-2696?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15868738#comment-15868738
] 

ASF GitHub Bot commented on ZOOKEEPER-2696:
-------------------------------------------

Github user afine commented on the issue:

    https://github.com/apache/zookeeper/pull/178
  
    Hi @rakeshadr 
    
    I was able to run the unit tests within eclipse or idea (I used WatcherTest as my example)
using just the dependencies I added in the patch.  
    
    That being said I would be find removing `transitive="false"`. I would appreciate @phunt
opinion on that as he added it originally. 
    



> Eclipse ant ask no longer determines correct classpath for tests after ZOOKEEPER-2689
> -------------------------------------------------------------------------------------
>
>                 Key: ZOOKEEPER-2696
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-2696
>             Project: ZooKeeper
>          Issue Type: Bug
>    Affects Versions: 3.4.10
>            Reporter: Abraham Fine
>            Assignee: Abraham Fine
>
> Following the changes made in ZOOKEEPER-2689 IDE's using the .classpath file generated
by the eclipse ant task (I tested both idea and eclipse) cannot compile the tests.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message