zookeeper-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ZOOKEEPER-2689) Fix Kerberos Authentication related test cases
Date Fri, 10 Feb 2017 17:12:41 GMT

    [ https://issues.apache.org/jira/browse/ZOOKEEPER-2689?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15861548#comment-15861548
] 

ASF GitHub Bot commented on ZOOKEEPER-2689:
-------------------------------------------

GitHub user rakeshadr opened a pull request:

    https://github.com/apache/zookeeper/pull/170

    ZOOKEEPER-2689: Fix Kerberos Authentication related test cases

    Presently 'MiniKdc.java' uses Apache Kerby which has a build requirement of jdk1.7+, http://directory.apache.org/kerby/developer-guide.html].
Since branch-3.4.x support Java 1.6 or higher, Apache Kerby binding is causing trouble.
    
    I've tried an attempt to rewrite MiniKdc.java test using old way of Kerberos implementation
provided by Apache Directory Server project, org.apache.directory.* packages. Please refer
MiniKdc implementation of Hadoop, trunk branch git hash revision 42e3a805117ff7cb054c2442f7b0e0cc54be63ad

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/rakeshadr/zookeeper-1 ZK-2689

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/zookeeper/pull/170.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #170
    
----
commit fd96cb96ed6b5974b9c6360fb6991a32744a4b34
Author: Rakesh Radhakrishnan <rakeshr@apache.org>
Date:   2017-02-10T17:02:15Z

    ZOOKEEPER-2689: Fix Kerberos Authentication related test cases

----


> Fix Kerberos Authentication related test cases
> ----------------------------------------------
>
>                 Key: ZOOKEEPER-2689
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-2689
>             Project: ZooKeeper
>          Issue Type: Bug
>          Components: tests
>    Affects Versions: 3.4.9
>            Reporter: Mohammad Arshad
>            Assignee: Rakesh R
>             Fix For: 3.4.10
>
>
> Following test classes failed when branch-3.4 is run on java 6.
> {noformat}
> org.apache.zookeeper.server.quorum.auth.MiniKdcTest
> org.apache.zookeeper.server.quorum.auth.QuorumKerberosAuthTest
> org.apache.zookeeper.server.quorum.auth.QuorumKerberosHostBasedAuthTest
> {noformat}
> Error message is {{org/apache/kerby/kerberos/kerb/KrbException : Unsupported major.minor
version 51.0}}



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message