zookeeper-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Olaf Flebbe (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ZOOKEEPER-2654) Support Fedora 25: use pkg-config instead of obsolete M4 macros
Date Thu, 22 Dec 2016 17:48:58 GMT

    [ https://issues.apache.org/jira/browse/ZOOKEEPER-2654?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15770646#comment-15770646
] 

Olaf Flebbe commented on ZOOKEEPER-2654:
----------------------------------------

One additinal benefit of this patch is that one does not need to have cppunit installed when
regenerating the autoconf files.


> Support Fedora 25: use pkg-config instead of obsolete M4 macros
> ---------------------------------------------------------------
>
>                 Key: ZOOKEEPER-2654
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-2654
>             Project: ZooKeeper
>          Issue Type: Bug
>          Components: build
>            Reporter: Olaf Flebbe
>            Assignee: Olaf Flebbe
>         Attachments: ZOOKEEPER-2654.patch
>
>
> While compiling Bigtop on Fedora 25 we found that there is an issue with the autoconf
detection of cppunit: See BIGTOP-2642 for error.
> Some background regarding the issue can be found here: https://bugzilla.redhat.com/show_bug.cgi?id=1311694
> The fedora maintainers encourage use of pkg-config rather crufty *.m4 autoconf magic
by only supplying pkg-config files *.pc.
> The patch is surprisingly easy but adds the additional requirement for pkg-config which
should be available on every well maintained system for ages.
> Please see for me proposed patch. Works for me for Fedora 25, Centos 6, MacOSX with HomeBrew.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message