zookeeper-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Brower (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ZOOKEEPER-1594) TestReconfig intermittently fails
Date Sat, 05 Nov 2016 08:29:58 GMT

    [ https://issues.apache.org/jira/browse/ZOOKEEPER-1594?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15638970#comment-15638970
] 

James Brower commented on ZOOKEEPER-1594:
-----------------------------------------

Hi, I am bringing this up 3 years after its last been discussed. I am trying to run unit tests
on the C client and am still having problems in the Zookeeper_reconfig set of tests. Is it
the same issue that has never been solved? I need to add more unit tests for a feature I'm
implementing but I don't know if its wise to do so until this is resolved.

> TestReconfig intermittently fails
> ---------------------------------
>
>                 Key: ZOOKEEPER-1594
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-1594
>             Project: ZooKeeper
>          Issue Type: Bug
>          Components: c client
>    Affects Versions: 3.5.0
>            Reporter: Marshall McMullen
>            Assignee: Marshall McMullen
>
> We've seen an intermittent failure in one of the C client tests TestReconfig which was
committed as part of ZOOKEEPER-1355.
> The test that is failing is failing *before* any rebalancing algorithm is invoked. After
inspecting this we've concluded it is a failure to properly seed the random number generator
properly. This same problem was seen and solved on the Java client side so we just need to
do something similar on the C client side.
> The assertion:
> Build/trunk/src/c/tests/TestReconfig.cc:571: Assertion: assertion failed [Expression:
numClientsPerHost.at(i) >= lowerboundClientsPerServer(numClients, numServers)]
> [exec] [exec] Failures !!!
> [exec] [exec] Run: 38 Failure total: 1 Failures: 1 Errors: 0
> [exec] [exec] make: *** [run-check] Error 1
> [exec] 
> [exec] BUILD FAILED
> [exec] /home/jenkins/jenkins-slave/workspace/PreCommit-ZOOKEEPER-Build/trunk/build.xml:1262:
The following error occurred while executing this line:
> [exec] /home/jenkins/jenkins-slave/workspace/PreCommit-ZOOKEEPER-Build/trunk/build.xml:1272:
exec returned: 2
> Also this one:
> From the latest build logs:
> [exec] Zookeeper_watchers::testChildWatcher2 : elapsed 54 : OK
> [exec] /home/jenkins/jenkins-slave/workspace/ZooKeeper-trunk/trunk/src/c/tests/TestReconfig.cc:183:
Assertion: equality assertion failed [Expected: 1, Actual : 0]
> [exec] Failures !!!
> [exec] Run: 67 Failure total: 1 Failures: 1 Errors: 0
> [exec] FAIL: zktest-mt
> [exe



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message