zookeeper-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Patrick Hunt (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ZOOKEEPER-2317) Non-OSGi compatible version
Date Tue, 03 May 2016 18:00:15 GMT

    [ https://issues.apache.org/jira/browse/ZOOKEEPER-2317?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15269215#comment-15269215
] 

Patrick Hunt commented on ZOOKEEPER-2317:
-----------------------------------------

Thanks [~niveau0]. Do you think this is worth addressing then? Personally I was hoping to
get it resolved prior to non-alpha/beta so that more folks could try it out. Unfortunately
I'm not in a position to develop/test the fix. Would you be able to provide a patch? Looks
like ant provides "propertyresource" that can do the replacement: http://stackoverflow.com/questions/1176071/replacing-characters-in-ant-property

> Non-OSGi compatible version
> ---------------------------
>
>                 Key: ZOOKEEPER-2317
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-2317
>             Project: ZooKeeper
>          Issue Type: Bug
>          Components: build
>    Affects Versions: 3.5.1
>         Environment: Karaf OSGi container
>            Reporter: Markus Tippmann
>            Priority: Blocker
>             Fix For: 3.5.2
>
>
> Bundle cannot be deployed to OSGi container.
> Manifest version is not OSGi compatible.
> Instead of using 3.5.1-alpha, manifest needs to contain 3.5.1.alpha



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message