zookeeper-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Liu Shaohui (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ZOOKEEPER-2191) Continue supporting prior Ant versions that don't implement the threads attribute for the JUnit task.
Date Tue, 19 May 2015 03:00:00 GMT

    [ https://issues.apache.org/jira/browse/ZOOKEEPER-2191?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14549713#comment-14549713
] 

Liu Shaohui commented on ZOOKEEPER-2191:
----------------------------------------

LGTM
Could someone help to push this issue?

> Continue supporting prior Ant versions that don't implement the threads attribute for
the JUnit task.
> -----------------------------------------------------------------------------------------------------
>
>                 Key: ZOOKEEPER-2191
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-2191
>             Project: ZooKeeper
>          Issue Type: Improvement
>          Components: build
>            Reporter: Chris Nauroth
>            Assignee: Chris Nauroth
>         Attachments: ZOOKEEPER-2191.001.patch
>
>
> ZOOKEEPER-2183 introduced usage of the threads attribute on the <junit> task call
in build.xml to speed up test execution.  This attribute is only available since Ant 1.9.4.
 However, we can continue to support older Ant versions by calling the <antversion>
task and dispatching to a clone of our <junit> task call that doesn't use the threads
attribute.  Users of older Ant versions will get the slower single-process test execution.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message