zookeeper-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Germán Blanco (JIRA) <j...@apache.org>
Subject [jira] [Commented] (ZOOKEEPER-1805) "Don't care" value in ZooKeeper election breaks rolling upgrades
Date Fri, 01 Nov 2013 05:43:23 GMT

    [ https://issues.apache.org/jira/browse/ZOOKEEPER-1805?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13811060#comment-13811060
] 

Germán Blanco commented on ZOOKEEPER-1805:
------------------------------------------

+1
Thank you [~rgs] and [~fpj] for spotting this and the quick fix before release of 3.4.6.
Only a very mild suggestion, if you wish you could remove the changes introduced by ZOOKEEPER-1732
in Leader.java, Learner.java and QuorumPeer.java. I think they don't do anything significant
anymore. Of course I might also be wrong, and the change would require testing things again,
so ...

> "Don't care" value in ZooKeeper election breaks rolling upgrades
> ----------------------------------------------------------------
>
>                 Key: ZOOKEEPER-1805
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-1805
>             Project: ZooKeeper
>          Issue Type: Bug
>            Reporter: Flavio Junqueira
>            Assignee: Flavio Junqueira
>            Priority: Blocker
>             Fix For: 3.4.6, 3.5.0
>
>         Attachments: ZOOKEEPER-1805-b3.4.patch, ZOOKEEPER-1805.patch, ZOOKEEPER-1805.patch,
ZOOKEEPER-1805.patch, ZOOKEEPER-1805.patch, ZOOKEEPER-1805.patch, ZOOKEEPER-1805.patch, ZOOKEEPER-1805.patch
>
>
> This is an issue that has been originally reported in ZOOKEEPER-1732.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message