zookeeper-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Flavio Junqueira (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ZOOKEEPER-1742) "make check" doesn't work on macos
Date Sun, 17 Nov 2013 11:37:21 GMT

    [ https://issues.apache.org/jira/browse/ZOOKEEPER-1742?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13824802#comment-13824802
] 

Flavio Junqueira commented on ZOOKEEPER-1742:
---------------------------------------------

The patch for 3.4 seems to work fine, just a couple of things I wanted to run by you. When
I run autoreconf, I'm getting a bunch warning:

{noformat}
Makefile.am:81: warning: wildcard ${srcdir}/tests/*.cc: non-POSIX variable name
Makefile.am:81: (probably a GNU make extension)
Makefile.am:81: warning: wildcard ${srcdir}/tests/*.h: non-POSIX variable name
Makefile.am:81: (probably a GNU make extension)
Makefile.am:92: warning: shell cat ${srcdir}/tests/wrappers.opt: non-POSIX variable name
Makefile.am:92: (probably a GNU make extension)
Makefile.am:105: warning: shell cat ${srcdir}/tests/wrappers-mt.opt: non-POSIX variable name
Makefile.am:105: (probably a GNU make extension)
/opt/local/share/automake-1.13/am/ltlibrary.am: warning: 'libhashtable.la': linking libtool
libraries using a non-POSIX
/opt/local/share/automake-1.13/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
Makefile.am:16:   while processing Libtool library 'libhashtable.la'
/opt/local/share/automake-1.13/am/ltlibrary.am: warning: 'libzkmt.la': linking libtool libraries
using a non-POSIX
/opt/local/share/automake-1.13/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
Makefile.am:48:   while processing Libtool library 'libzkmt.la'
/opt/local/share/automake-1.13/am/ltlibrary.am: warning: 'libzkmt_test.la': linking libtool
libraries using a non-POSIX
/opt/local/share/automake-1.13/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
Makefile.am:16:   while processing Libtool library 'libzkmt_test.la'
/opt/local/share/automake-1.13/am/ltlibrary.am: warning: 'libzkst.la': linking libtool libraries
using a non-POSIX
/opt/local/share/automake-1.13/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
Makefile.am:16:   while processing Libtool library 'libzkst.la'
/opt/local/share/automake-1.13/am/ltlibrary.am: warning: 'libzkst_test.la': linking libtool
libraries using a non-POSIX
/opt/local/share/automake-1.13/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
Makefile.am:16:   while processing Libtool library 'libzkst_test.la'
/opt/local/share/automake-1.13/am/ltlibrary.am: warning: 'libzookeeper_mt.la': linking libtool
libraries using a non-POSIX
/opt/local/share/automake-1.13/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
Makefile.am:53:   while processing Libtool library 'libzookeeper_mt.la'
/opt/local/share/automake-1.13/am/ltlibrary.am: warning: 'libzookeeper_st.la': linking libtool
libraries using a non-POSIX
/opt/local/share/automake-1.13/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
Makefile.am:35:   while processing Libtool library 'libzookeeper_st.la'
{noformat}

Is this expected?

Also, there are these two error messages that seem to be harmless, but they are there:

{noformat}
cat: ./tests/wrappers.opt: No such file or directory
cat: ./tests/wrappers-mt.opt: No such file or directory
{noformat}

> "make check" doesn't work on macos
> ----------------------------------
>
>                 Key: ZOOKEEPER-1742
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-1742
>             Project: ZooKeeper
>          Issue Type: Bug
>    Affects Versions: 3.4.5, 3.5.0
>            Reporter: Flavio Junqueira
>            Assignee: Benjamin Reed
>             Fix For: 3.4.6, 3.5.0
>
>         Attachments: ZOOKEEPER-1742-3.4.patch, ZOOKEEPER-1742.patch, ZOOKEEPER-1742.patch
>
>
> There are two problems I have spotted when running "make check" with the C client. First,
it complains that the sleep call is not defined in two test files: tests/ZooKeeperQuorumServer.cc
and tests/TestReconfigServer.cc. Including unistd.h works. The second problem is with linker
options. It complains that "--wrap" is not a valid. I'm not sure how to deal with this one
yet, since I'm not sure why we are using it.  



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message