zookeeper-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Weise (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ZOOKEEPER-1655) Make jline dependency optional in maven pom
Date Mon, 02 Sep 2013 16:20:53 GMT

    [ https://issues.apache.org/jira/browse/ZOOKEEPER-1655?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13756154#comment-13756154
] 

Thomas Weise commented on ZOOKEEPER-1655:
-----------------------------------------

I think leaking the jline dependency is not desirable because it is only
needed to run the ZK command line tools while most projects would only use
the client API. For example, jline made its way into the
Hadoopdistribution until it was excluded explicitly.

As for upgrading jlline, that's a good idea as it would make features such
as reverse history search available in the ZK CLI.




                
> Make jline dependency optional in maven pom
> -------------------------------------------
>
>                 Key: ZOOKEEPER-1655
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-1655
>             Project: ZooKeeper
>          Issue Type: Bug
>          Components: build
>    Affects Versions: 3.4.2
>            Reporter: Thomas Weise
>            Assignee: Thomas Weise
>             Fix For: 3.5.0, 3.4.6
>
>         Attachments: ZOOKEEPER-1655.patch
>
>
> Old JLine version used in ZK CLI should not be pulled into downstream projects. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message