zookeeper-bookkeeper-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ivan Kelly (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (BOOKKEEPER-60) confusion between multiple "consume" methods
Date Thu, 01 Sep 2011 16:22:09 GMT

    [ https://issues.apache.org/jira/browse/BOOKKEEPER-60?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13095380#comment-13095380
] 

Ivan Kelly commented on BOOKKEEPER-60:
--------------------------------------

I think Subscribe.consume is correct. I'd change MessageHandler#consume to MessageHandler#deliver
instead. However, this would be an API change, which Im not sure how to do. If I remember
correct, we only make API breaks between major versions, so this would have to go in 4.0.0,
which I think could be a long way away. 

> confusion between multiple "consume" methods
> --------------------------------------------
>
>                 Key: BOOKKEEPER-60
>                 URL: https://issues.apache.org/jira/browse/BOOKKEEPER-60
>             Project: Bookkeeper
>          Issue Type: Improvement
>          Components: hedwig-client
>            Reporter: Matthieu Morel
>            Priority: Minor
>
> There are currently 2 methods named "consume" in the client API:
> - in org.apache.hedwig.client.api.MessageHandler : delegates the processing of a message
by a message handler
> - in org.apache.hedwig.client.api.Subscriber : notifies the server that messages have
been processed till a given sequence id. This is some kind of acknowledgement.
> I don't think these 2 fundamental methods should be named the same: they have different
purposes and it is confusing.
> Couldn't we rename Subscriber.consume into Subscriber.acknowledge, or something similar?

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message