zipkin-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jorge Esteban Quilcate Otoya <quilcate.jo...@gmail.com>
Subject Re: Delete Kafka 0.8 support
Date Tue, 07 May 2019 07:57:53 GMT
+1

Haven't work with Kafka <1.0 for a while. As example, Confluent (Kafka
distribution) is ending support for Kafka 0.11 (Confluent 3.3) on August
1st, keeping only >1.0 supported onward:
https://docs.confluent.io/current/installation/versions-interoperability.html

Jorge.

El mar., 7 may. 2019 a las 2:49, Adrian Cole (<adrian.f.cole@gmail.com>)
escribió:

> Hi, team.
>
> We are readying release announcement for Zipkin 2.13 (it is pending
> IPMC vote still). I think we should say this is the last version we
> publish Kafka 0.8 support.
>
> I can't find any support matrix from Kafka, but it is very old, almost
> 4 years old since last release of Kafka 0.8. Removing this will
> improve our build times which are close to the limits. It will also
> reduce the size of our docker image and the complexity of creating it.
>
> Note that this does not mean remove Kafka, Just brokers before version
> 0.10.
>
> WDYT?
> -Adrian
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@zipkin.apache.org
> For additional commands, e-mail: dev-help@zipkin.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message