zipkin-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GitBox <...@apache.org>
Subject [GitHub] [incubator-zipkin-website] dependabot[bot] opened a new pull request #20: Bump nokogiri from 1.10.3 to 1.10.5
Date Fri, 01 Nov 2019 12:21:09 GMT
dependabot[bot] opened a new pull request #20: Bump nokogiri from 1.10.3 to 1.10.5
URL: https://github.com/apache/incubator-zipkin-website/pull/20
 
 
   Bumps [nokogiri](https://github.com/sparklemotion/nokogiri) from 1.10.3 to 1.10.5.
   <details>
   <summary>Release notes</summary>
   
   *Sourced from [nokogiri's releases](https://github.com/sparklemotion/nokogiri/releases).*
   
   > ## 1.10.5 / 2019-10-31
   > 
   > ### Dependencies
   > 
   > * [MRI] vendored libxml2 is updated from 2.9.9 to 2.9.10
   > * [MRI] vendored libxslt is updated from 1.1.33 to 1.1.34
   > 
   > 
   > 
   > ## 1.10.4 / 2019-08-11
   > 
   > ### Security
   > 
   > #### Address CVE-2019-5477 ([#1915](https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/1915))
   > 
   > A command injection vulnerability in Nokogiri v1.10.3 and earlier allows commands
to be executed in a subprocess by Ruby's `Kernel.open` method. Processes are vulnerable only
if the undocumented method `Nokogiri::CSS::Tokenizer#load_file` is being passed untrusted
user input.
   > 
   > This vulnerability appears in code generated by the Rexical gem versions v1.0.6 and
earlier. Rexical is used by Nokogiri to generate lexical scanner code for parsing CSS queries.
The underlying vulnerability was addressed in Rexical v1.0.7 and Nokogiri upgraded to this
version of Rexical in Nokogiri v1.10.4.
   > 
   > This CVE's public notice is [sparklemotion/nokogiri#1915](https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/1915)
   > 
   </details>
   <details>
   <summary>Changelog</summary>
   
   *Sourced from [nokogiri's changelog](https://github.com/sparklemotion/nokogiri/blob/master/CHANGELOG.md).*
   
   > ## 1.10.5 / 2019-10-31
   > 
   > ### Dependencies
   > 
   > * [MRI] vendored libxml2 is updated from 2.9.9 to 2.9.10
   > * [MRI] vendored libxslt is updated from 1.1.33 to 1.1.34
   > 
   > 
   > ## 1.10.4 / 2019-08-11
   > 
   > ### Security
   > 
   > #### Address CVE-2019-5477 ([#1915](https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/1915))
   > 
   > A command injection vulnerability in Nokogiri v1.10.3 and earlier allows commands
to be executed in a subprocess by Ruby's `Kernel.open` method. Processes are vulnerable only
if the undocumented method `Nokogiri::CSS::Tokenizer#load_file` is being passed untrusted
user input.
   > 
   > This vulnerability appears in code generated by the Rexical gem versions v1.0.6 and
earlier. Rexical is used by Nokogiri to generate lexical scanner code for parsing CSS queries.
The underlying vulnerability was addressed in Rexical v1.0.7 and Nokogiri upgraded to this
version of Rexical in Nokogiri v1.10.4.
   > 
   > This CVE's public notice is [sparklemotion/nokogiri#1915](https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/1915)
   </details>
   <details>
   <summary>Commits</summary>
   
   - [`1bc2ff9`](https://github.com/sparklemotion/nokogiri/commit/1bc2ff9f6218e1f814b18040e5bbb49b7b7bf60b)
version bump to v1.10.5
   - [`383c1f8`](https://github.com/sparklemotion/nokogiri/commit/383c1f8ee833cb63ca93fe3ecfe8d93755a993b6)
update CHANGELOG
   - [`43a1753`](https://github.com/sparklemotion/nokogiri/commit/43a175339b47b8c604508813fc75b83f13cd173e)
dependency: update libxslt to 1.1.34 final
   - [`99d8a6b`](https://github.com/sparklemotion/nokogiri/commit/99d8a6b6ec83077652a06a333571e4705120f022)
dependency: update libxml to 2.9.10 final
   - [`2a86496`](https://github.com/sparklemotion/nokogiri/commit/2a86496ca565aa283c4fd9cd247d21c6026d7b61)
add suppressions for ruby 2.7
   - [`dca794a`](https://github.com/sparklemotion/nokogiri/commit/dca794a716fb285e2b19f8e028e61e4e3613ed14)
update CHANGELOG with correct release date for v1.10.4
   - [`077e010`](https://github.com/sparklemotion/nokogiri/commit/077e010613cfb41f8cc03383c3e3b901a3985a49)
update rake-compiler commands to install bundler
   - [`beb832e`](https://github.com/sparklemotion/nokogiri/commit/beb832e3a67ba9aef1b4e83640bc8fd08fbc6da5)
version bump to v1.10.4
   - [`5d30128`](https://github.com/sparklemotion/nokogiri/commit/5d30128343573a9428c86efc758ba2c66e9f12dc)
Merge branch '1915-css-tokenizer-load-file-vulnerability_v1.10.x' into v1.10.x
   - [`c86b5fc`](https://github.com/sparklemotion/nokogiri/commit/c86b5fc02e5b50308d8de08b9a194aa71b701081)
update CHANGELOG
   - Additional commits viewable in [compare view](https://github.com/sparklemotion/nokogiri/compare/v1.10.3...v1.10.5)
   </details>
   <br />
   
   [![Dependabot compatibility score](https://dependabot-badges.githubapp.com/badges/compatibility_score?dependency-name=nokogiri&package-manager=bundler&previous-version=1.10.3&new-version=1.10.5)](https://help.github.com/articles/configuring-automated-security-fixes)
   
   Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself.
You can also trigger a rebase manually by commenting `@dependabot rebase`.
   
   [//]: # (dependabot-automerge-start)
   [//]: # (dependabot-automerge-end)
   
   ---
   
   <details>
   <summary>Dependabot commands and options</summary>
   <br />
   
   You can trigger Dependabot actions by commenting on this PR:
   - `@dependabot rebase` will rebase this PR
   - `@dependabot recreate` will recreate this PR, overwriting any edits that have been made
to it
   - `@dependabot merge` will merge this PR after your CI passes on it
   - `@dependabot squash and merge` will squash and merge this PR after your CI passes on
it
   - `@dependabot cancel merge` will cancel a previously requested merge and block automerging
   - `@dependabot reopen` will reopen this PR if it is closed
   - `@dependabot ignore this [patch|minor|major] version` will close this PR and stop Dependabot
creating any more for this minor/major version (unless you reopen the PR or upgrade to it
yourself)
   - `@dependabot ignore this dependency` will close this PR and stop Dependabot creating
any more for this dependency (unless you reopen the PR or upgrade to it yourself)
   - `@dependabot use these labels` will set the current labels as the default for future
PRs for this repo and language
   - `@dependabot use these reviewers` will set the current reviewers as the default for future
PRs for this repo and language
   - `@dependabot use these assignees` will set the current assignees as the default for future
PRs for this repo and language
   - `@dependabot use this milestone` will set the current milestone as the default for future
PRs for this repo and language
   
   You can disable automated security fix PRs for this repo from the [Security Alerts page](https://github.com/apache/incubator-zipkin-website/network/alerts).
   
   </details>

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


With regards,
Apache Git Services

Mime
View raw message