zipkin-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From adrianc...@apache.org
Subject [incubator-zipkin-dependencies] 01/01: Updates to latest Zipkin and ES 7, dropping ES v2-5
Date Tue, 04 Jun 2019 05:07:55 GMT
This is an automated email from the ASF dual-hosted git repository.

adriancole pushed a commit to branch es7
in repository https://gitbox.apache.org/repos/asf/incubator-zipkin-dependencies.git

commit 3e4657499e4f3b50b4abc3aed4f3d12ca55b7416
Author: Adrian Cole <acole@pivotal.io>
AuthorDate: Tue Jun 4 13:07:11 2019 +0800

    Updates to latest Zipkin and ES 7, dropping ES v2-5
---
 README.md                                          |  7 +++++
 .../cassandra/CassandraRowsToDependencyLinks.java  |  3 +-
 .../cassandra/v1/ITCassandraDependencies.java      |  2 +-
 .../storage/cassandra/ITCassandraDependencies.java |  2 +-
 elasticsearch/pom.xml                              |  3 +-
 .../ElasticsearchDependenciesJob.java              | 17 +++++-----
 .../ITElasticsearchV5Dependencies.java             | 36 ----------------------
 .../ITElasticsearchV6Dependencies.java             |  2 +-
 ...ies.java => ITElasticsearchV7Dependencies.java} |  4 +--
 pom.xml                                            | 10 +++---
 10 files changed, 29 insertions(+), 57 deletions(-)

diff --git a/README.md b/README.md
index f0bf3e4..bd88815 100644
--- a/README.md
+++ b/README.md
@@ -13,6 +13,13 @@ just prior to midnight UTC.
 All Zipkin [Storage Components](https://github.com/apache/incubator-zipkin/blob/master/zipkin-storage/)
 are supported, including Cassandra, MySQL and Elasticsearch.
 
+## Versions
+
+`STORAGE_TYPE=cassandra3` - requires Cassandra 3.11.3+; tested against the latest patch of
3.11
+`STORAGE_TYPE=cassandra` - requires Cassandra 2.2+; tested against the latest patch of 3.11
+`STORAGE_TYPE=mysql` - requires MySQL 5.6+; tested against MariaDB 10.3
+`STORAGE_TYPE=elasticsearch` - requires Elasticsearch 5+; tested against last minor release
of 6.x and 7.x
+
 ## Quick-start
 
 The quickest way to get started is to fetch the [latest released job](https://search.maven.org/remote_content?g=org.apache.zipkin.dependencies&a=zipkin-dependencies&v=LATEST)
as a self-contained jar.
diff --git a/cassandra/src/main/java/zipkin2/dependencies/cassandra/CassandraRowsToDependencyLinks.java
b/cassandra/src/main/java/zipkin2/dependencies/cassandra/CassandraRowsToDependencyLinks.java
index 2b44244..9cc9da6 100644
--- a/cassandra/src/main/java/zipkin2/dependencies/cassandra/CassandraRowsToDependencyLinks.java
+++ b/cassandra/src/main/java/zipkin2/dependencies/cassandra/CassandraRowsToDependencyLinks.java
@@ -28,6 +28,7 @@ import scala.Serializable;
 import zipkin2.DependencyLink;
 import zipkin2.Span;
 import zipkin2.internal.DependencyLinker;
+import zipkin2.internal.ReadBuffer;
 import zipkin2.internal.V1ThriftSpanReader;
 import zipkin2.v1.V1Span;
 import zipkin2.v1.V1SpanConverter;
@@ -55,7 +56,7 @@ final class CassandraRowsToDependencyLinks
     List<Span> sameTraceId = new ArrayList<>();
     for (CassandraRow row : rows) {
       try {
-        V1Span v1Span = reader.read(row.getBytes("span"));
+        V1Span v1Span = reader.read(ReadBuffer.wrapUnsafe(row.getBytes("span")));
         for (Span span : converter.convert(v1Span)) {
           // check to see if the trace is within the interval
           if (span.parentId() == null) {
diff --git a/cassandra/src/test/java/zipkin2/storage/cassandra/v1/ITCassandraDependencies.java
b/cassandra/src/test/java/zipkin2/storage/cassandra/v1/ITCassandraDependencies.java
index 19ded47..f28315f 100644
--- a/cassandra/src/test/java/zipkin2/storage/cassandra/v1/ITCassandraDependencies.java
+++ b/cassandra/src/test/java/zipkin2/storage/cassandra/v1/ITCassandraDependencies.java
@@ -40,7 +40,7 @@ import static org.assertj.core.api.Assertions.assertThat;
 public class ITCassandraDependencies extends ITDependencies {
   @ClassRule
   public static CassandraStorageRule cassandraStorageRule =
-      new CassandraStorageRule("openzipkin/zipkin-cassandra:2.13.0");
+      new CassandraStorageRule("openzipkin/zipkin-cassandra:2.14.0");
 
   @Rule public TestName testName = new TestName();
 
diff --git a/cassandra3/src/test/java/zipkin2/storage/cassandra/ITCassandraDependencies.java
b/cassandra3/src/test/java/zipkin2/storage/cassandra/ITCassandraDependencies.java
index f027307..0121f82 100644
--- a/cassandra3/src/test/java/zipkin2/storage/cassandra/ITCassandraDependencies.java
+++ b/cassandra3/src/test/java/zipkin2/storage/cassandra/ITCassandraDependencies.java
@@ -38,7 +38,7 @@ import static org.assertj.core.api.Assertions.assertThat;
 public class ITCassandraDependencies extends ITDependencies {
   @ClassRule
   public static CassandraStorageRule cassandraStorageRule =
-      new CassandraStorageRule("openzipkin/zipkin-cassandra:2.13.0");
+      new CassandraStorageRule("openzipkin/zipkin-cassandra:2.14.0");
 
   @Rule public TestName testName = new TestName();
 
diff --git a/elasticsearch/pom.xml b/elasticsearch/pom.xml
index 6d81f23..1856380 100644
--- a/elasticsearch/pom.xml
+++ b/elasticsearch/pom.xml
@@ -37,8 +37,7 @@
     <dependency>
       <groupId>org.elasticsearch</groupId>
       <artifactId>elasticsearch-spark-20_${scala.binary.version}</artifactId>
-      <!-- locked as future versions break elasticsearch 2.x -->
-      <version>6.3.2</version>
+      <version>7.1.1</version>
     </dependency>
 
     <dependency>
diff --git a/elasticsearch/src/main/java/zipkin2/dependencies/elasticsearch/ElasticsearchDependenciesJob.java
b/elasticsearch/src/main/java/zipkin2/dependencies/elasticsearch/ElasticsearchDependenciesJob.java
index 1b90da5..6dc5657 100644
--- a/elasticsearch/src/main/java/zipkin2/dependencies/elasticsearch/ElasticsearchDependenciesJob.java
+++ b/elasticsearch/src/main/java/zipkin2/dependencies/elasticsearch/ElasticsearchDependenciesJob.java
@@ -163,15 +163,16 @@ public final class ElasticsearchDependenciesJob {
   }
 
   public void run() {
-    run( // multi-type index
-        index + "-" + dateStamp + "/span",
-        index + "-" + dateStamp + "/dependencylink",
-        SpanBytesDecoder.JSON_V1);
-
     run( // single-type index
-        index + ":span-" + dateStamp + "/span",
-        index + ":dependency-" + dateStamp + "/dependency",
-        SpanBytesDecoder.JSON_V2);
+      index + ":span-" + dateStamp + "/span",
+      index + ":dependency-" + dateStamp + "/dependency",
+      SpanBytesDecoder.JSON_V2);
+
+    run( // single-type index with ES 7+
+      index + "-span-" + dateStamp,
+      index + "-dependency-" + dateStamp,
+      SpanBytesDecoder.JSON_V2);
+
     log.info("Done");
   }
 
diff --git a/elasticsearch/src/test/java/zipkin2/elasticsearch/ITElasticsearchV5Dependencies.java
b/elasticsearch/src/test/java/zipkin2/elasticsearch/ITElasticsearchV5Dependencies.java
deleted file mode 100644
index 5d1e56c..0000000
--- a/elasticsearch/src/test/java/zipkin2/elasticsearch/ITElasticsearchV5Dependencies.java
+++ /dev/null
@@ -1,36 +0,0 @@
-/*
- * Licensed to the Apache Software Foundation (ASF) under one or more
- * contributor license agreements.  See the NOTICE file distributed with
- * this work for additional information regarding copyright ownership.
- * The ASF licenses this file to You under the Apache License, Version 2.0
- * (the "License"); you may not use this file except in compliance with
- * the License.  You may obtain a copy of the License at
- *
- *     http://www.apache.org/licenses/LICENSE-2.0
- *
- * Unless required by applicable law or agreed to in writing, software
- * distributed under the License is distributed on an "AS IS" BASIS,
- * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
- * See the License for the specific language governing permissions and
- * limitations under the License.
- */
-package zipkin2.elasticsearch;
-
-import org.junit.ClassRule;
-
-public class ITElasticsearchV5Dependencies extends ITElasticsearchDependencies {
-
-  @ClassRule
-  public static LazyElasticsearchStorage storage =
-      new LazyElasticsearchStorage("openzipkin/zipkin-elasticsearch5:2.13.0");
-
-  @Override
-  protected ElasticsearchStorage esStorage() {
-    return storage.get();
-  }
-
-  @Override
-  protected String esNodes() {
-    return storage.esNodes();
-  }
-}
diff --git a/elasticsearch/src/test/java/zipkin2/elasticsearch/ITElasticsearchV6Dependencies.java
b/elasticsearch/src/test/java/zipkin2/elasticsearch/ITElasticsearchV6Dependencies.java
index 669bd41..5a4efbd 100644
--- a/elasticsearch/src/test/java/zipkin2/elasticsearch/ITElasticsearchV6Dependencies.java
+++ b/elasticsearch/src/test/java/zipkin2/elasticsearch/ITElasticsearchV6Dependencies.java
@@ -22,7 +22,7 @@ public class ITElasticsearchV6Dependencies extends ITElasticsearchDependencies
{
 
   @ClassRule
   public static LazyElasticsearchStorage storage =
-      new LazyElasticsearchStorage("openzipkin/zipkin-elasticsearch6:2.13.0");
+      new LazyElasticsearchStorage("openzipkin/zipkin-elasticsearch6:2.14.0");
 
   @Override
   protected ElasticsearchStorage esStorage() {
diff --git a/elasticsearch/src/test/java/zipkin2/elasticsearch/ITElasticsearchV2Dependencies.java
b/elasticsearch/src/test/java/zipkin2/elasticsearch/ITElasticsearchV7Dependencies.java
similarity index 93%
rename from elasticsearch/src/test/java/zipkin2/elasticsearch/ITElasticsearchV2Dependencies.java
rename to elasticsearch/src/test/java/zipkin2/elasticsearch/ITElasticsearchV7Dependencies.java
index cae802c..ceef156 100644
--- a/elasticsearch/src/test/java/zipkin2/elasticsearch/ITElasticsearchV2Dependencies.java
+++ b/elasticsearch/src/test/java/zipkin2/elasticsearch/ITElasticsearchV7Dependencies.java
@@ -18,11 +18,11 @@ package zipkin2.elasticsearch;
 
 import org.junit.ClassRule;
 
-public class ITElasticsearchV2Dependencies extends ITElasticsearchDependencies {
+public class ITElasticsearchV7Dependencies extends ITElasticsearchDependencies {
 
   @ClassRule
   public static LazyElasticsearchStorage storage =
-      new LazyElasticsearchStorage("openzipkin/zipkin-elasticsearch:2.13.0");
+      new LazyElasticsearchStorage("openzipkin/zipkin-elasticsearch7:2.14.0");
 
   @Override
   protected ElasticsearchStorage esStorage() {
diff --git a/pom.xml b/pom.xml
index 00fa864..9d8848a 100755
--- a/pom.xml
+++ b/pom.xml
@@ -52,22 +52,22 @@
     <!-- can't switch to 2.12 until spark-cassandra-connector updates -->
     <scala.binary.version>2.11</scala.binary.version>
     <spark.version>2.4.1</spark.version>
-    <zipkin.version>2.13.0</zipkin.version>
+    <zipkin.version>2.14.0</zipkin.version>
     <junit.version>4.12</junit.version>
     <assertj.version>3.12.2</assertj.version>
     <jackson.version>2.9.8</jackson.version>
     <!-- keep this in sync with zipkin's version -->
-    <okhttp.version>3.14.1</okhttp.version>
+    <okhttp.version>3.14.2</okhttp.version>
     <!-- connector uses an old version of the driver -->
     <cassandra-driver-core.version>3.7.1</cassandra-driver-core.version>
     <spark-cassandra-connector.version>2.4.1</spark-cassandra-connector.version>
-    <testcontainers.version>1.11.2</testcontainers.version>
+    <testcontainers.version>1.11.3</testcontainers.version>
 
     <maven-compiler-plugin.version>3.8.1</maven-compiler-plugin.version>
     <maven-install-plugin.version>3.0.0-M1</maven-install-plugin.version>
     <maven-deploy-plugin.version>3.0.0-M1</maven-deploy-plugin.version>
-    <maven-source-plugin.version>3.0.1</maven-source-plugin.version>
-    <maven-javadoc-plugin.version>3.0.1</maven-javadoc-plugin.version>
+    <maven-source-plugin.version>3.1.0</maven-source-plugin.version>
+    <maven-javadoc-plugin.version>3.1.0</maven-javadoc-plugin.version>
     <license-maven-plugin.version>3.0</license-maven-plugin.version>
     <maven-jar-plugin.version>3.1.2</maven-jar-plugin.version>
     <maven-shade-plugin.version>3.2.1</maven-shade-plugin.version>


Mime
View raw message