zeppelin-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jongy...@apache.org
Subject zeppelin git commit: [DOC][ZEPPELIN-1209] Remove a useless sentence about default interpreter in docs
Date Wed, 03 Aug 2016 08:51:44 GMT
Repository: zeppelin
Updated Branches:
  refs/heads/master 9eac20d08 -> 16b320ff9


[DOC][ZEPPELIN-1209] Remove a useless sentence about default interpreter in docs

### What is this PR for?
As new interpreter registration mechanism which was started in [ZEPPELIN-804](https://issues.apache.org/jira/browse/ZEPPELIN-804),
we can't set default interpreter anymore using `zeppelin-site.xml` as described in [https://zeppelin.apache.org/docs/0.7.0-SNAPSHOT/install/install.html#apache-zeppelin-configuration](https://zeppelin.apache.org/docs/0.7.0-SNAPSHOT/install/install.html#apache-zeppelin-configuration)
(see `zeppelin.interpreters` property description in the configuration table). So we need
to remove the related contents in Zeppelin docs site.

Below pages will be updated:
 - [https://zeppelin.apache.org/docs/0.7.0-SNAPSHOT/install/install.html#apache-zeppelin-configuration](https://zeppelin.apache.org/docs/0.7.0-SNAPSHOT/install/install.html#apache-zeppelin-configuration)
 - [https://zeppelin.apache.org/docs/0.7.0-SNAPSHOT/development/writingzeppelininterpreter.html#060-and-later](https://zeppelin.apache.org/docs/0.7.0-SNAPSHOT/development/writingzeppelininterpreter.html#060-and-later)

### What type of PR is it?
Documentation

### What is the Jira issue?
[ZEPPELIN-1209](https://issues.apache.org/jira/browse/ZEPPELIN-1209)

### How should this be tested?
No need to test. Just removed two sentences about the default interpreter setting.

### Screenshots (if appropriate)

### Questions:
* Does the licenses files need update? no
* Is there breaking changes for older versions? no
* Does this needs documentation? no

Author: AhyoungRyu <fbdkdud93@hanmail.net>

Closes #1207 from AhyoungRyu/ZEPPELIN-1209 and squashes the following commits:

61108f4 [AhyoungRyu] Add a sentence about the deprecation
9f44f22 [AhyoungRyu] Remove useless sentence about default interpreter in docs


Project: http://git-wip-us.apache.org/repos/asf/zeppelin/repo
Commit: http://git-wip-us.apache.org/repos/asf/zeppelin/commit/16b320ff
Tree: http://git-wip-us.apache.org/repos/asf/zeppelin/tree/16b320ff
Diff: http://git-wip-us.apache.org/repos/asf/zeppelin/diff/16b320ff

Branch: refs/heads/master
Commit: 16b320ff92875f9d0cf623d0516c766b8ecc4670
Parents: 9eac20d
Author: AhyoungRyu <fbdkdud93@hanmail.net>
Authored: Wed Jul 20 17:10:00 2016 +0900
Committer: Jongyoul Lee <jongyoul@apache.org>
Committed: Wed Aug 3 17:51:38 2016 +0900

----------------------------------------------------------------------
 docs/development/writingzeppelininterpreter.md | 1 -
 docs/install/install.md                        | 5 ++++-
 2 files changed, 4 insertions(+), 2 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/zeppelin/blob/16b320ff/docs/development/writingzeppelininterpreter.md
----------------------------------------------------------------------
diff --git a/docs/development/writingzeppelininterpreter.md b/docs/development/writingzeppelininterpreter.md
index d40101b..8061a89 100644
--- a/docs/development/writingzeppelininterpreter.md
+++ b/docs/development/writingzeppelininterpreter.md
@@ -156,7 +156,6 @@ println(a)
 
 ### 0.6.0 and later
 Inside of a notebook, `%[INTERPRETER_GROUP].[INTERPRETER_NAME]` directive will call your
interpreter.
-Note that the first interpreter configuration in zeppelin.interpreters will be the default
one.
 
 You can omit either [INTERPRETER\_GROUP] or [INTERPRETER\_NAME]. If you omit [INTERPRETER\_NAME],
then first available interpreter will be selected in the [INTERPRETER\_GROUP].
 Likewise, if you skip [INTERPRETER\_GROUP], then [INTERPRETER\_NAME] will be chosen from
default interpreter group.

http://git-wip-us.apache.org/repos/asf/zeppelin/blob/16b320ff/docs/install/install.md
----------------------------------------------------------------------
diff --git a/docs/install/install.md b/docs/install/install.md
index 98adc74..6450db0 100644
--- a/docs/install/install.md
+++ b/docs/install/install.md
@@ -380,7 +380,10 @@ You can configure Apache Zeppelin with both **environment variables**
in `conf/z
     <td>org.apache.zeppelin.spark.SparkInterpreter,<br />org.apache.zeppelin.spark.PySparkInterpreter,<br
/>org.apache.zeppelin.spark.SparkSqlInterpreter,<br />org.apache.zeppelin.spark.DepInterpreter,<br
/>org.apache.zeppelin.markdown.Markdown,<br />org.apache.zeppelin.shell.ShellInterpreter,<br
/>
     ...
     </td>
-    <td>Comma separated interpreter configurations [Class] <br /> The first interpreter
will be a default value. <br /> It means only the first interpreter in this list can
be available without <code>%interpreter_name</code> annotation in notebook paragraph.
</td>
+    <td>
+      Comma separated interpreter configurations [Class] <br/>
+      <span style="font-style:italic">NOTE: This property is deprecated since Zeppelin-0.6.0
and will not be supported from Zeppelin-0.7.0</span>
+    </td>
   </tr>
   <tr>
     <td>ZEPPELIN_INTERPRETER_DIR</td>


Mime
View raw message