xmlgraphics-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Glenn Adams <gl...@skynav.com>
Subject Re: Java 1.6 as Minimum Requirement
Date Wed, 09 Oct 2013 13:37:21 GMT
On Wed, Oct 9, 2013 at 5:01 AM, Chris Bowditch
<bowditch_chris@hotmail.com>wrote:

> Hi Vincent,
>
> before making such a decision I'd like to weigh up pros and cons of such a
> proposal. The only pro that I can detect is improved support for
> annotations. IIUC, there aren't many language changes between Java 5 and 6,
> so the benefits to a developer will be small.
>

There are a few new, very useful APIs in Java 6, such as:

   - String.isEmpty()
   - Arrays.copyOf(), copyOfRange()
   - Collections.newSetFromMap()
   - Deque

More differences are described at:

http://www.oracle.com/technetwork/java/javase/features-141434.html


>
> The obvious con is that we restrict our user base. Whilst its true that
> Java 5 is long out of support from Oracle, there are many other platforms
> such as AIX, HP-UX, Solaris etc where installing newer JDKs is really
> difficult because of all the pre-requisite Operating System patches
> required. Also, Oracle aren't the only JDK vendors and we do have clients
> with IBM JDK 5, which is still supported. A lot of bigger Enterprises won't
> be able to upgrade from Java 5 to Java 6 across all platforms and this
> could restrict our user base quite significantly.
>
> Since the benefit to the developers appears small, I'm inclined not to
> support such a motion. I could possibly be convinced that the upgrade would
> be more beneficial to developers than I'm currently aware. So please feel
> free to convince me :-)
>
> Thanks,
>
> Chris
>
>
> On 08/10/2013 12:51, Vincent Hennebert wrote:
>
>> Hi,
>>
>> it seems that people are having more and more trouble to compile their
>> code on a 1.5 JDK. Also, Java 1.5 is getting really old now with the end
>> of public updates dating as far back as October 2009.
>>
>> So maybe it’s time to drop support for Java 1.5 and switch to 1.6 as
>> a minimum requirement for the next versions of XGC, FOP and Batik.
>>
>> WDYT?
>>
>> Thanks,
>> Vincent
>>
>> ------------------------------**------------------------------**---------
>> To unsubscribe, e-mail: general-unsubscribe@**xmlgraphics.apache.org<general-unsubscribe@xmlgraphics.apache.org>
>> For additional commands, e-mail: general-help@xmlgraphics.**apache.org<general-help@xmlgraphics.apache.org>
>>
>>
>>
>>
>
> ------------------------------**------------------------------**---------
> To unsubscribe, e-mail: general-unsubscribe@**xmlgraphics.apache.org<general-unsubscribe@xmlgraphics.apache.org>
> For additional commands, e-mail: general-help@xmlgraphics.**apache.org<general-help@xmlgraphics.apache.org>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message