xmlgraphics-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Manuel Mall <man...@apache.org>
Subject Re: build problems with java 1.4
Date Wed, 09 Jun 2010 10:05:21 GMT


J.Pietschmann wrote:
> 
> On 07.06.2010 10:12, Simon Pepping wrote:
>> So, once we have proven that the code can be compiled with jdk 1.4
>> without such warnings, we can safely compile with jdk 1.6?
> 
> Well, the logical answer should be "Yes" but then I've had builds
> in the past where results didn't quite match the theory.
> 
> J.Pietschmann
> 
> 
I had problems in the past. For example

    new BigDecimal(1)

compiles under Java 1.4 into

   public BigDecimal(double val)

but under 1.5 and later it compiles into (introduced in 1.5)

   public BigDecimal(int val)

So the same code compiles fine under both platforms but because of the new
constructor signatures introduced the code compiled under 1.5 will not run
under 1.4.

May be there is a compiler switch telling it to ignore methods/constructors
with an @since Javadoc comment later than the target platform but I don't
think so.
-- 
View this message in context: http://old.nabble.com/build-problems-with-java-1.4-tp28752403p28828248.html
Sent from the Xml Graphics - General mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: general-help@xmlgraphics.apache.org


Mime
View raw message