xmlgraphics-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simon Pepping <spepp...@leverkruid.eu>
Subject Re: build problems with java 1.4
Date Mon, 07 Jun 2010 08:12:18 GMT
On Sun, Jun 06, 2010 at 07:57:58PM +0200, J.Pietschmann wrote:
> On 04.06.2010 19:45, Simon Pepping wrote:
> >I have a question: The ant build file says:
> >
> >property name="javac.target" value="1.4"
> >
> >Why is that not enough? Does it not cause sdk 6 to do compilation for
> >java 1.4?
> 
> This generates bytecode compatible with a 1.4 JVM but doesn't
> flag RTL functionality which is in 1.5+ but not in 1.4, therefore
> if somehow 1.5+ features have crept in, the result is likely
> unusable in a 1.4 environment.

So, once we have proven that the code can be compiled with jdk 1.4
without such warnings, we can safely compile with jdk 1.6?

Simon

-- 
Simon Pepping
home page: http://www.leverkruid.eu

---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: general-help@xmlgraphics.apache.org


Mime
View raw message