xmlgraphics-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simon Pepping <spepp...@leverkruid.eu>
Subject Re: build problems with java 1.4
Date Wed, 02 Jun 2010 19:46:24 GMT
>ant compile
Buildfile: /fsc/source/xmlgraphics-commons-branch-1_4/build.xml

info:
     [echo] ------------------- Apache XML Graphics Commons 1.4 [1999-2010] ----------------
     [echo] See build.properties and build-local.properties for additional build settings
     [echo] Apache Ant version 1.8.0 compiled on March 11 2010
     [echo] VM: 1.4.2_11-b06, Sun Microsystems Inc.
     [echo] JAVA_HOME: /usr/local/java

init-avail:
     [echo] Sun-private JPEG Support PRESENT
     [echo] JUnit Support PRESENT
     [echo] IKVM Support NOT Present

...

compile-copy-resources:
     [copy] Copying 8 files to /fsc/source/xmlgraphics-commons-branch-1_4/build/classes

BUILD FAILED
/fsc/source/xmlgraphics-commons-branch-1_4/build.xml:196: Failed to copy /fsc/source/xmlgraphics-commons-branch-1_4/src/resources/META-INF/services/org.apache.xmlgraphics.image.loader.spi.ImageLoaderFactory
to /fsc/source/xmlgraphics-commons-branch-1_4/build/classes/META-INF/services/org.apache.xmlgraphics.image.loader.spi.ImageLoaderFactory
due to Invalid argument

>$JAVA_HOME/bin/java -version
java version "1.4.2_11"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_11-b06)
Java HotSpot(TM) Client VM (build 1.4.2_11-b06, mixed mode)


On Wed, Jun 02, 2010 at 05:19:49PM +0200, Jeremias Maerki wrote:
> I've just compiled the branch using Sun JDK 1.4.2_19 on by Ubuntu 9.04
> and that worked fine. What Ant version are you using? I get the
> following at the beginning of the build:
> 
> info:
>      [echo] ------------------- Apache XML Graphics Commons 1.4 [1999-2010] ----------------
>      [echo] See build.properties and build-local.properties for additional build settings
>      [echo] Apache Ant version 1.7.1 compiled on June 27 2008
>      [echo] VM: 1.4.2_19-b04, Sun Microsystems Inc.
>      [echo] JAVA_HOME: /opt/j2sdk1.4.2_19
> 
> init-avail:
>      [echo] Sun-private JPEG Support PRESENT
>      [echo] JUnit Support PRESENT
>      [echo] IKVM Support NOT Present
> 
> Just for comparison:
> 
> jeremias@atom:~/dev/xgc-branch$ $JAVA_HOME/bin/java -version
> java version "1.4.2_19"
> Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_19-b04)
> Java HotSpot(TM) Client VM (build 1.4.2_19-b04, mixed mode)
> 
> The only thing I'm struggling with is getting Xvfb or PJA working on
> that headless server, so the tests don't currently run through.

-- 
Simon Pepping
home page: http://www.leverkruid.eu

---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: general-help@xmlgraphics.apache.org


Mime
View raw message