xmlgraphics-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vincent Hennebert <vincent.henneb...@anyware-tech.com>
Subject Re: [DRAFT] Preparing a user poll for JDK 1.3 compatibility
Date Mon, 01 Oct 2007 13:51:28 GMT
Wow. I wouldn’t have done better. It’s fine for me.

Thanks,
Vincent

Jeremias Maerki a écrit :
> I said earlier that I want a user poll and a vote before changing the
> minimal JDK version to support for FOP (and Batik). Now that I have more
> time for XML Graphics again, I should probably follow up on that. I
> would like to set up one of those online surveys to get some feedback
> from the users prior to the vote. I'm thinking about putting up the
> following questions:
> 
> 1. Which Apache XML Graphics subprojects do you use?
>   a) Apache Batik (SVG)          yes/no/don't know  Version: ______
>   b) Apache FOP (XSL-FO)         yes/no/don't know  Version: ______
>   c) Apache XML Graphics Commons yes/no/don't know  Version: ______
> 
> 2. What operating system are you on?
>   Windows    dev/prod   Version: ________
>   Linux      dev/prod   Version: ________
>   Solaris    dev/prod   Version: ________
>   BSD        dev/prod   Version: ________
>   MacOSX     dev/prod   Version: ________
>   AIX        dev/prod   Version: ________
>   other no1  dev/prod   Name&Version: ________
>   other no2  dev/prod   Name&Version: ________
> 
> 3. What hardware are you running your production systems on?
>   ___________________________________________________
> 
> 4. What Java Virtual Machine versions do you use in development (Brand &
> Version of the JVMs in use)?
>   _____________________________________________
> 
> 5. What Java Virtual Machine versions do you use in production (Brand &
> Version of the JVMs in use)?
>   _____________________________________________
> 
> 6. If you use Java 1.3 or earlier in production, do you have a need to
> stay on the latest versions of Apache XML Graphics products?
>    o yes, because: _________________________________________________
>    o no
>    o I run Java 1.4 or later.
> 
> 7. If you use Java 1.3 or earlier in production, what's the reason you
> cannot migrate to Java 1.4 or later?
>    o There's no Java 1.4 or later for the operating system we use.
>    o There's some software that doesn't run on 1.4 or later so we're
> stuck.
>    o Company policy
>   Other comments/reasons: _____________________________________________
> 
> 8. Are you aware that the end-of-life process for Sun's Java 1.3 has
> ended in December 2006?
>    o yes
>    o no
> 
> 9. Anything else you would like to tell us while you're at it?
>    ______________________________________________
> 
> Any other questions you want answered? Any objection to taking Batik and
> Commons into the same questionaire and make the "Java 1.4 question" a
> project vote rather than a subproject vote?
> 
> Thanks,
> Jeremias Maerki


---------------------------------------------------------------------
Apache XML Graphics Project URL: http://xmlgraphics.apache.org/
To unsubscribe, e-mail: general-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: general-help@xmlgraphics.apache.org


Mime
View raw message