xmlgraphics-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From The Web Maestro <the.webmaes...@gmail.com>
Subject Re: Minimum J2SE requirements for XML Graphics
Date Thu, 12 Oct 2006 05:00:59 GMT
I am in favour of setting the minimum J2SE to 1.4 after the 0.93  
release.

+1

Web Maestro Clay

On Oct 9, 2006, at 7:11 AM, Simon Pepping wrote:
> I am in favour of setting the minimum J2SE to 1.4 after the 0.93
> release.
>
> Simon
>
> On Mon, Oct 09, 2006 at 11:58:27AM +0200, Jeremias Maerki wrote:
>> Last week on the Cocoon GetTogether we discussed J2SE requirements  
>> for
>> FOP. I brought it up because the end-of-life phase for J2SE 1.3.1  
>> ends
>> soon, probably this month. See:
>> http://java.sun.com/j2se/1.3/download.html
>>
>> There was an argument on Cocoon-dev which gave me a new view on the
>> topic:
>> http://www.nabble.com/-Vote--Java-5-as-minimum-JDK-requirement- 
>> tf2072590.html#a5718669
>> http://www.nabble.com/-poll--Java-5-as-minimum-requirement-for- 
>> Cocoon-2.2-tf2083663.html
>>
>> In short, the argument was made that a company who is still on J2SE
>> 1.3.1 would probably not upgrade their system and still stay on  
>> 1.3.1 so
>> they also don't need any new XML Graphics releases on 1.3.1. Applying
>> this and the fact that Sun will drop normal support for J2SE 1.3.1 by
>> the end of October (if J2SE 6.0 is delivered on time), we can  
>> probably
>> safely up our minimum requirements to 1.4.2, making our lives a  
>> little
>> easier for releases after the EOL of J2SE 1.3.1.
>>
>> I send this here because for Batik and Commons the same question  
>> can be
>> raised. Thomas indicated himself that it becomes increasingly  
>> difficult
>> to keep everything compatible with J2SE 1.3. And my impression is the
>> same.
>>
>> My proposal would be to do this: Poll the FOP and Batik user  
>> communities
>> again for the necessity to still support new releases on J2SE 1.3
>> specifically asking why people are still on 1.3 but having the  
>> need to
>> upgrade their FOP and/or Batik installation. I'd then propose to  
>> release
>> Commons 1.1 and FOP 0.93 still with support for J2SE 1.3 but  
>> setting the
>> minimum J2SE to 1.4 after that. Batik could already do this for  
>> the next
>> release as this will still take a while to finish I think.
>>
>> Thoughts?


---------------------------------------------------------------------
Apache XML Graphics Project URL: http://xmlgraphics.apache.org/
To unsubscribe, e-mail: general-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: general-help@xmlgraphics.apache.org


Mime
View raw message