xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Glenn Adams <gl...@skynav.com>
Subject Re: Configuring fonts for an embeded FOP 1.0
Date Wed, 26 Oct 2011 14:01:04 GMT
OK, in that case, I suggest you try the following:

(1) in your FOP xconf file, remove any font triplets, and just specify
<auto-detect/>, e.g.,

    <renderer mime="application/pdf">
      <filterList>
        <value>flate</value>
      </filterList>
      <fonts>
        <auto-detect/>
      </fonts>
    </renderer>

(2) instead of specifying font-weight="bolder", try specifying specific
weights, e.g., 500, 600, 700, ...

(3) instead of specifying font-family="Arial Narrow", try specifying "Arial
Narrow MT"

On Wed, Oct 26, 2011 at 9:42 PM, Heiko <techteam@gmx.de> wrote:

>  No, I have no svg or other image in my content. :(
>
>
> Am 26.10.2011 15:22, schrieb Glenn Adams:
>
> Do you happen to use an SVG file in your content? If so, there was a bug in
> mapping SVG font sizes into FOP font sizes, which has been fixed in the
> current trunk, but was not fixed in FOP-1.0. You might try using the current
> trunk instead of FOP-1.0.
>
>  G.
>
> On Wed, Oct 26, 2011 at 9:16 PM, Heiko <techteam@gmx.de> wrote:
>
>> Hi,
>> I use FOP 1.0 inside an Eclipse RCP client to generate different pdf
>> reports.
>> Inside my xslt file, I have lines like:
>>
>> <fo:block font-family="Arial Narrow" font-size="14pt" font-style="normal"
>> font-weight="bolder" padding-bottom="18pt" margin="0pt" space-before="6pt"
>> space-after="6pt">
>>
>> While debugging the report generation process I looked inside the
>> FopFactory -> FontManager -> FontCache ->FontFileMap
>> and found the following line:
>>
>> null=metrics-url=ARIALN.xml, embed-url=ARIALN.ttf, kerning=true,
>> enc-mode=EncodingMode:auto, font-triplet=[Arial Narrow,normal,400, Arial
>> Narrow MT,normal,400]
>>
>> This should be the correct font(file) for the above defined font
>>
>> But while proccessing the data I get the following errors:
>>
>> 26.10.2011 14:16:15 org.apache.fop.events.LoggingEventListener
>> processEvent
>> WARNUNG: Font "Arial Narrow,normal,500" not found. Substituting with
>> "any,normal,400".
>> 26.10.2011 14:16:16 org.apache.fop.events.LoggingEventListener
>> processEvent
>> WARNUNG: Font "Arial Narrow,normal,400" not found. Substituting with
>> "any,normal,400".
>> 26.10.2011 14:16:17 org.apache.fop.events.LoggingEventListener
>> processEvent
>> WARNUNG: Font "Arial Narrow,normal,700" not found. Substituting with
>> "any,normal,700".
>>
>> If I understand it right, when I don't define a base font URL, FOP looks
>> for at the system font path for all fonts  or?
>>
>> What di I have to do (programaticlly) that FOP knows my wished font?
>>
>> Thanks in advance
>>
>> Heiko
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
>> For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org
>>
>>
>
>

Mime
View raw message