xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Spyros Papantoniou <spyros.papanton...@gmail.com>
Subject Re: Normal + italic fonts work; but bold appears normal
Date Mon, 03 Oct 2011 22:27:27 GMT
YES!!!

Thankyou!!!!!
the mix up of style and weight caused the ####s.

Now: Greek and Latin show correctly after fixing the userconfig:

arialΠΡΟΣΚΛΗΣΗ+bold      times weightboldΠΡΟΣΚΛΗΣΗ  arialbold #########

Times and Arial fixed!


On Oct 4, 2011, at 1:06 AM, Rob Sargent wrote:

> I really don't think you're 'font-style="bold"' is correct. That is for "normal" and
"italics" (and others?).  That's why "stylebold" is not bold.  "weightbold" is bold because
you have set the font-weight correctly.  
> 'font-family="ArialBold" ' probably needs to be 'font-family="ArialBlack" ' because that's
what you have in your config file.
> 
> 
> To get the Cyrillic characters you will need to use a different font family and mixing
latin and greek characters will be a pain: many separate in-lines necessary.  I'm sure your
mac has Cyrillic fonts but your config file doesn't include a reference to any.  Not sure
where that hide those on macs these days but /usr/share/fonts/cyrillic is where they _should_
be. :)
> 
>   
> On 10/03/2011 02:24 PM, Spyros Papantoniou wrote:
>> 
>> Rob, u
>> I Tried a few things after your encouragment, here is the outpt:
>> 
>> stylebold#########times weightbold#########arialbold #########
>>  Times bold did print the latin glyphs, but not the Greek (displayed as (###))
>> 
>> ArialBold, does not print though.
>> 
>> fop:
>> 
>>     <fo:inline   font-family="Times"  font-style="bold" >styleboldΠΡΟΣΚΛΗΣΗ</fo:inline>
<fo:inline font-family="Times" font-weight="bold" >times  weightboldΠΡΟΣΚΛΗΣΗ</fo:inline>
<fo:inline font-family="ArialBold" font-style="normal">arialbold ΠΡΟΣΚΛΗΣΗ</fo:inline>
</fo:block>
>> 
>> any ideas? I use MacOSX 10.6.8 (dev), and windows 2003 server (prod)
>> 
>> many thanks
>> Spyros
>> 
>> 
>> On Oct 3, 2011, at 10:39 PM, Rob Sargent wrote:
>> 
>>> 
>>> 
>>> On 10/03/2011 01:26 PM, Spyros Papantoniou wrote:
>>>> 
>>>> Hello xml-poets,
>>>> 
>>>> Can some one cast some light in why bold is not printing?
>>>> my userconfig.xml is:
>>>> 
>>>> <fop version="1.0">
>>>>   <renderers>
>>>>     <renderer mime="application/pdf">
>>>>       <fonts>
>>>>     
>>>>        <font kerning="yes" 
>>>>    embed-url="file:///C:/WINDOWS/Fonts/ARIAL.ttf">  
>>>>    <font-triplet name="Arial" style="normal" weight="400"/>
>>>>         </font>
>>>>         <font kerning="yes"  
>>>>    embed-url="file:///C:/WINDOWS/Fonts/ARIALI.ttf">
>>>>    <font-triplet name="Arial" style="italic" weight="400"/>
>>>>         </font>
>>>>         <font kerning="yes" 
>>>>           embed-url="file:///C:/WINDOWS/Fonts/ARIALBD.ttf">
>>>>           <font-triplet name="Arial" style="bold" weight="bold"/>
>>>>         </font>
>>>> 
>>>>         <font kerning="yes" 
>>>>    embed-url="file:///C:/WINDOWS/Fonts/ariblk.ttf">  
>>>>    <font-triplet name="ArialBlack" style="normal" weight="normal"/>
>>>>         </font>
>>>>         <font kerning="yes"  
>>>>    embed-url="file:///C:/WINDOWS/Fonts/ariblk.ttf">
>>>>    <font-triplet name="ArialBlack" style="italic" weight="normal"/>
>>>>         </font>
>>>>         <font kerning="yes" 
>>>>           embed-url="file:///C:/WINDOWS/Fonts/ariblk.ttf">
>>>>           <font-triplet name="ArialBlack" style="bold" weight="bold"/>
>>>>         </font>
>>>> 
>>>>       </fonts>
>>>>     </renderer>
>>>>    </renderers>
>>>> </fop>
>>>> 
>>>> Trying to display some text in bold, but it shows only normal.  though Italic
is also ok.
>>>> I use ArialBlack as a donkeybridge ( aka Eselsbruecke), unitl some divine
light is cast upon me.
>>>> 
>>>> Any ideal how to make bold appear? font-style="??"  font-weight="???" or
what else shall I use?
>>>> 
>>>> 
>>>>  <fo:block font-size="12pt" font-family="Arial" text-align="left"  font-weight="1800"
 font-weight="bold"   font-style="bold "  >     <!-- NOT WORKING shows normal , font-style="italic"
is ok though-->
>>> I doubt you have a weight of 1800, nor is there a font-style called bold.  That
should be normal or italic.
>>>>       <fo:inline font-family="ArialBlack"> ΠΡΟΣ </fo:inline>
: Ολα τα μέλη του Συμβουλίου </fo:block>          <!-- in-line
Arialblack OK   -->
>>>>      
>>>>  <fo:block font-size="12pt" font-family="Arial" text-align="left" >
>>>>       Σύμφωνα με το άρθρο 2 παρ.3 του Ν. 2083/92 σας
καλούμε στην <xsl:value-of select="$councilNumber"/>η Συνεδρίαση
του Πρυτανικού Συμβουλίου ακαδ. έτους <xsl:value-of select="$academicYear"/>

>>>>       της <xsl:value-of select="$toDay"/>/<xsl:value-of select="$toMonth"/>/<xsl:value-of
select="$toYear"/> και ώρα <xsl:value-of select="$hour"/> στην <xsl:value-of
select="$place"/> με τα ακόλουθα θέματα:
>>>>        
>>>>        </fo:block>
>>>>        <fo:block id="">&#160;</fo:block>
>>>>        <fo:block font-size="14pt" font-family="ArialBlack" text-align="left"
font-weight="normal" space-before="48pt" space-after="22pt">   OK
>>>>          ΘΕΜΑΤΑ ΗΜΕΡΗΣΙΑΣ ΔΙΑΤΑΞΗΣ
>>>>        </fo:block>
>>>> 
>>>> 
>> 


Mime
View raw message