xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simon Pepping <spepp...@leverkruid.eu>
Subject Re: Building fop from source on debian
Date Thu, 25 Aug 2011 19:09:14 GMT
Hi Mathieu,

I am beginning to understand that you are not reporting problems in
FOP's build process, but in Debian's build process of the FOP package.

I looked at debian bug reports 638532 and 639162 and FOP bug report
50575. All three reports seem to refer to binaries and sources of
Linux distributions, viz. RHEL and Debian. The problems reported seem
to be due to the build process in those distributions, which is
different from the build process provided by the FOP team. Those
problems should be solved by the maintainers of those distributions.
The FOP team is only responsible for FOP's own build process and the
binaries published by us. It is therefore not right report those
problems in a FOP bug report or to forward debian bug report 639162 to
the FOP bug report.

As a debian user and fan I would be willing to help debugging the
problem, and I would like to see fop 1.0 in the testing distribution,
but I would rather address other priorities. I also note from the
Debian bug report 638532 that the maintainers report the problem as
solved, although report 639162 contradicts that.

The event models, of which there are currently 16, all named
event.xml, are generated from the java code. In FOP's own build
process, that happens in the eventResourceGenerator task, which is run
after the compile-java task, the compilation of
${src.codegen.dir}/java, and the copying of
${src.codegen.dir}/java/**/*.xsl. I guess that in your build process
some of these steps were not performed successfully.

Best, Simon

On Tue, Aug 23, 2011 at 12:23:07PM +0200, Mathieu Malaterre wrote:
> Hi Simon,
> 
>   Thanks for taking the time to answer my question.
> 
> On Mon, Aug 22, 2011 at 8:31 PM, Simon Pepping <spepping@leverkruid.eu> wrote:
> > This should not happen. I looks like an error in the order of the
> > build targets. How did you run the build? Which ant version and which
> > java in which version are you using?
> 
> ant is version 1.8.2-3 (debian)
> java is:
> java version "1.6.0_18"
> OpenJDK Runtime Environment (IcedTea6 1.8.7) (6b18-1.8.7-2~squeeze1)
> OpenJDK 64-Bit Server VM (build 14.0-b16, mixed mode)
> 
> We are only building the following two targets:
> DEB_ANT_BUILD_TARGET := package javadocs
> 
> And the classpath is set to (during build):
> 
> DEB_JARS             := $(ANT_HOME)/lib/ant-trax.jar batik-all
> xml-apis-ext batik-libs xml-apis avalon-framework xercesImpl
> xmlParserAPIs xalan2 junit commons-io commons-logging
> xmlgraphics-commons servlet-api-2.4 qdox
> 
> >> Reported as:
> >> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=638532
> >
> > Your build errors are not fop bugs, unless proven. No thanks.
> 
> This is what surprised me when I saw a Null pointer exception being
> raised in the code. Starring at the code I could not understand if
> this was part of the pre-condition or if there is an issue with the
> code which does not support null pointer.

---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message