xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steffanina, Jeff" <Jeff.Steffan...@marriott.com>
Subject Error when using XSL with French Characters
Date Wed, 03 Sep 2008 02:22:53 GMT

My Friends,
Fop-0.95   My style sheet has been working perfectly.  However, the user submitted some text
in French.  In the text was a letter "e" with an accent above it.

That character caused the following error:
	Invalid byte 1 of 1-byte UTF-8 sequence.

My .xml looks fine.   The  "e" with the accent above it is perfect.
First line in my XML:
	<?xml version="1.0" encoding="UTF-8"?>

Here is the first line of my XSL:
	<?xml version="1.0" encoding="UTF-8"?>

I am confused over why the UTF-8 for the XML understands the character but the UTF-8 in the
XSL does not?

I found an article that suggests that the problem would be solved with: 
	<?xml version="1.0" encoding="8859-1"?>

Would this be a viable/recommended solution?   Do you have a better idea?


Jeff Steffanina
FOSSE Development,  Bethesda, MD
(301)380-2047
jeff.steffanina@marriott.com

    This communication contains information from Marriott International, Inc. that may be
confidential. Except for personal use by the intended recipient, or as expressly authorized
by the sender, any person who receives this information is prohibited from disclosing, copying,
distributing, and/or using it. If you have received this communication in error, please immediately
delete it and all copies, and promptly notify the sender. Nothing in this communication is
intended as an electronic signature under applicable law.



Mime
View raw message