xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Kelly <dke...@scriptorium.com>
Subject Lines not breaking with zero width space characters inserted
Date Fri, 20 Jul 2007 18:55:31 GMT
Greetings,

I have looked at the threads relating to line break issues as well as looking at various documentation
on how to force
line breaks.  From what I have read, it appears that inserting a zero-width space character
in a long string should
enable the string to be broken at the ZWS character when it spans a column edge (in my case,
a very narrow table
column).  I have succeeded in inserting various kinds of "breakable" characters after underscores
(which are common in
the strings I'm trying to break).  However, the only character that actually causes a break
is a full space character,
&#x0020; .  Other characters I've tried include the ZWS U+200B, soft hyphen U+00AD, and
hair space U+200A -- but these
do not appear to enable line breaking for me.

I am using FOP 0.93 in a Windows environment. I'm also using an en-US hyphenation table from
OFFO.

What I would like to find out is:

1. Should the ZWS work, and if so, what might cause it not to work?

2. Are there alternatives for creating a line-break after an underscore?  (I tried customizing
a hyphenation pattern in
the en_US.xml hyphenation file and pointing the cfg.xml <hyphenation_base> to point
to its directory, but this did not
appear to work for me either - output shows the hyphenation file is being read, but the new
pattern apparently is not
being processed.  I tried changing the hyphen character in the en-US.xml file, and that did
not get picked up either.

Sorry to put more than one issue in a message - I've been working on this problem for way
too long with little result.

Any pointers would be appreciated.

Thanks,
David Kelly


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message