xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Bowditch <bowditch_ch...@hotmail.com>
Subject Re: ClassCastException
Date Mon, 02 Apr 2007 11:01:10 GMT
Daniel Noll wrote:

> Chris Bowditch wrote:
> 
>> <snip/>
>>
>>> Has anyone seen this exception before?  Is it a bug in FOP, or is it 
>>> solveable by filtering the FO file to repair it somehow?
>>
>>
>> I've seen similar ClassCastExceptions, but they were caused by 
>> fo:wrapper being in places FOP didn't expect. In your case I believe 
>> the error is caused by the block-container expecting an fo:block as 
>> its parent. Since the fo:inline element doesn't appear to be doing 
>> anything (no properties have been set on it), you can remove it 
>> without changing the output and the error should disappear.
> 
> 
> All elements had properties, actually.  I removed them, partially so 
> that I could figure out which part of the document caused the problem, 
> but also to get a bare example to post here.

Ok. But just to prove what the cause of the problem is, did you try 
removing the fo:inline or changing the fo:inline to fo:block? IIC, once 
you have done this the FO should generate output and avoid the 
ClassCastException.

I then recommend that you raise a bug in bugzilla and attach your FO. 
This will esnure the Developers don't forget about this problem!

Thanks,

Chris




---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message