xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Amarnath Mukherjee <amar...@gmail.com>
Subject Problem related to Preview
Date Fri, 13 Apr 2007 13:06:55 GMT

Hi ,
I am using FOP 0.92 beta to show preview . I make a 
org.apache.fop.render.awt.viewer.PreviewPanel and add this object to a
JPanel to show the preview . Sometimes I am getting blank on  PreviewPanel .
Why is this happening ? please look at my code and suggest a solution .


Here is the code snippet I used ::

m_renderer = new AWTRenderer();
renderable = new InputHandler(foFile);
m_renderer.setRenderable(renderable);
foUserAgent.setRendererOverride(m_renderer);
m_renderer.setPreviewDialogDisplayed(false);
m_renderer.setUserAgent(foUserAgent);
renderable.renderTo(foUserAgent, MimeConstants.MIME_FOP_AWT_PREVIEW);

m_fopPreviewPanel = new
org.apache.fop.render.awt.viewer.PreviewPanel(foUserAgent, renderable,
m_renderer);
m_centerPanel.add(m_fopPreviewPanel);
m_renderer.clearViewportList();
m_fopPreviewPanel.reload();


Thanks and regards,
Amarnath Mukherjee
-- 
View this message in context: http://www.nabble.com/Problem-related-to-Preview-tf3571498.html#a9978594
Sent from the FOP - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message