xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Harshini Madurapperuma <harshini.madurapper...@ifs.lk>
Subject RE: Add Image Behind text to AWT preview
Date Fri, 27 Apr 2007 08:53:10 GMT
Hi there;

background-image option works when rendering a pdf file but does not works
when rendering a awt...?? Is this corret? Is there any other way to set a
background image to AWT preview?

I tried out it in this way:

<fo:simple-page-master element-id="my_layout2_7" page-width="21cm"
page-height="29.7cm" master-name="repeat-page" margin-top="1cm"
margin-right="1cm" margin-left="1.4999999999999998cm" margin-bottom="1cm"
margin="1.5cm">
<fo:region-body element-id="my_layout2_8" region-name="xsl-region-body"
margin-top="2cm" margin-bottom="1cm"/>
<fo:region-before element-id="my_layout2_9" region-name="repeat-page-head"
extent="2cm"/>
<fo:region-after element-id="my_layout2_10" region-name="repeat-page-foot"
extent="1cm"/>
</fo:simple-page-master>

<fo:simple-page-master element-id="my_layout2_11" page-width="21cm"
page-height="29.7cm" master-name="first-page" margin-top="1cm"
margin-right="1cm" margin-left="1.4999999999999998cm" margin-bottom="1cm"
margin="1.5cm">
<fo:region-body element-id="my_layout2_12" region-name="xsl-region-body"
margin-top="26.700000000000003cm" margin-bottom="1cm"
background-image="url(D:\Sparx
Work\pictures\report_designer_graphics\FNDBAS\FND_SESSION_REP\watermark.jpg)
"/>
<fo:region-before element-id="my_layout2_13" region-name="first-page-head"
extent="26.700000000000003cm"/>
<fo:region-after element-id="my_layout2_14" region-name="repeat-page-foot"
extent="1cm"/>
</fo:simple-page-master>
----------------------------------------------------------------------------
----------------------------------------
Also tried out in this way: 
background-image="D:/Sparx
Work/pictures/report_designer_graphics/FNDBAS/FND_SESSION_REP/watermark.jpg"

instead of 
background-image="url(D:\Sparx
Work\pictures\report_designer_graphics\FNDBAS\FND_SESSION_REP\watermark.jpg)
"

Regards;
Harshini


-----Original Message-----
From: Jeremias Maerki [mailto:dev@jeremias-maerki.ch] 
Sent: Friday, April 27, 2007 12:48 PM
To: fop-users@xmlgraphics.apache.org
Subject: Re: Add Image Behind text to AWT preview

I wonder what "not working" means. The attached FO files gives you some
ideas. Verified with the AWT preview of FOP 0.93. Works as expected.

On 24.04.2007 11:49:13 Harshini Madurapperuma wrote:
>  
> >Have you tried specifying background-image attribute on 
> >fo:region-body
> element?
> 
> Yes I tried but it's not working for AWT preview.
> /Harshini
> 
> 
> -----Original Message-----
> From: Chris Bowditch [mailto:bowditch_chris@hotmail.com]
> Sent: Tuesday, April 24, 2007 3:12 PM
> To: fop-users@xmlgraphics.apache.org
> Subject: Re: Add Image Behind text to AWT preview
> 
> Harshini Madurapperuma wrote:
> 
> > Hi all;
> >  
> > Is there a way to add a Image behind text (a kind of background
> > image) to AWT preview?
> 
> Have you tried specifying background-image attribute on fo:region-body 
> element?
> 
> Chris


Jeremias Maerki

---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message