xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas L Delmelle <a_l.delme...@pandora.be>
Subject Re: Problem with custom fonts
Date Sat, 14 Apr 2007 19:07:19 GMT
On Apr 14, 2007, at 20:55, Thomas Zastrow wrote:

> Andreas L Delmelle wrote:
>> On Apr 14, 2007, at 17:41, Thomas Zastrow wrote:
>>
>>> <snip />
>>> The files LinLibertine.xml and LinLibertineU-Re-2.2.5.ttf are in the
>>> root-directory of the FOP (version 0.93). The base-tag in the
>>> config-file is untouched, it is still   <base>.</base>
>>
>> Keep in mind that they are influenced by <font-base>. I /think/ both
>> of them. At least, I hope so... :/
>>
> OK, I added <font-base>.</font-base> to the fop.xconf. But the  
> result is
> the same ... btw., I'm not sure which directory is meant with "."?

Errm, if I'm correct then the "." is to be interpreted as relative to  
the source document...
In any case, now that you mention it, it does seem to lean towards  
bad practice to use a relative url as base-url for anything... :/

> Is it the conf-directory? Or the root-directory? I copied both the  
> metric xml
> file and the ttf-file also to conf, but FOP still can't find them.
>
> Is conf/fop.xconf read by default or have I to specify it as config- 
> file?

You have to specify it. The fop.xconf file contains the settings that  
are used by FOP if no config file is specified, but the file itself  
is not used unless you tell FOP to use it. If you leave it unchanged,  
and start FOP with "-c conf/fop.xconf", then the result is the same  
as if no config file has been used.

Cheers,

Andreas


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message