xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dirk Bromberg <bromb...@tzi.de>
Subject Re: Font embedding FOP dev
Date Wed, 28 Sep 2005 06:24:29 GMT
Ok,

thanks. with file:///E:/mypath_to_font.... it works...

btw: the path to the metrics can be setup as relative path to the 
"startup dir" but the "fontpath has to be absolute..."

Dirk

Manuel Mall wrote:
> On Wed, 28 Sep 2005 05:07 am, Andreas L Delmelle wrote:
>   
>> On Sep 27, 2005, at 22:27, Dirk Bromberg wrote:
>>     
>>> i wants to test to switch my project from 20.5 to dev.
>>>
>>> Now i want to embedd my ttf fonts via the fop.xconf.
>>>       
>> <snip />
>>
>>     
>>> but i always get the exception "D:\mypath_to_run\ArialUNI.xml
>>> FileNotFoundException" .... the Path is not relative to the xconf!
>>> it is relative to my running directory.
>>>       
>> Ouch! The user-configuration functionality is not fully ported yet,
>> especially the baseURL bit... Sorry. The entry is present in
>> fop.xconf, but currently serves no purpose.
>>
>> Since I do need to finish up a few things in that area of the code,
>> most likely I'll be able to squeeze it in during the weekend.
>>
>>     
>>> How can i set the right directory? I've tried to set the
>>> D:\mypath_to_run\confdir as basePath via the
>>> fop.getUserAgent().setBaseURL(...) but there was no change...
>>>       
>> The only way I see that might --note: not 100% sure-- temporarily
>> solve your problem is to include the full pathnames in the
>> font-triplet (possibly even as full 'file://' URLs to avoid them from
>> being interpreted as a relative URLs)
>>
>> Why the baseURL isn't taken into account when building the font-list,
>> I'm not certain, but this does mean that even if I complete the
>> user-configurable baseURL, it still won't work as it did before...
>>
>> For now, try out with absolute URLs in the triplets. As far as I
>> understand the related code, that should do the trick.
>>
>>     
>
> This is a known problem with the trunk code (see 
> http://issues.apache.org/bugzilla/show_bug.cgi?id=36729). I had a look 
> at fixing it but it involves changes to the font subsystem. That area 
> of code is currently being completely rewritten (integration of a 3rd 
> party font system) and I would expect this to be fixed as part of that 
> work. However, this may not happen in a real hurry.
>
> For the time being you have to use absolute paths or to be more correct 
> full URLs in your font definition files, that is everything must start 
> with file:// as Andreas suggested and be fully qualified.
>
>   
>> If not, don't hesitate to report back.
>>
>> HTH!
>>
>> Cheers,
>>
>> Andreas
>>
>>     
> Manuel
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
> For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org
>   

---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message