xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremias Maerki <...@jeremias-maerki.ch>
Subject Re: Can't get PNG images
Date Wed, 21 Sep 2005 09:21:28 GMT
Please make sure that the JAI libraries are in the class path when you
run FOP. I assume they are currently not.

On 21.09.2005 01:37:08 Oosterbaan, Douglas S. (LNG-DAY) wrote:
> 
> For some reason, I'm not able to include PNG images in my PDF 
> documents.  I'm trying to use jai rather than jimi for this.
> I downloaded the fop0.20.5 source code and installed
> the jai_core.jar and jai_codec.jar files under the
> .../fop-0.20.5/lib directory, then built everything using build.sh.
> 
> Interestingly, in the messages coming out to the screen I saw:
> prepare-jimi:
> 
> prepare-jai:
>      [echo] JAI library is present. Installing JAI support.
> 
> But in the build.log that gets created I saw:
> prepare-jimi:
> 
> prepare-jai:
> 
> I don't know why the prepare-jai: target is different between the
> two, or if that's even what my problem is.  I understand the 
> jimi lib not being present since that's not distributed with the 
> source for licensing issues.
> 
> In my testing, I have a directory that contains jpg's, bmp's, and
> png's.  I'm able to pick up all of the jpg's and bmp's but not any
> of the png's.
> 
> FWIW, my fop.jar does contain at least the following JAI image class:
> 3698 Fri Aug 19 13:56:40 EDT 2005 org/apache/fop/image/JAIImage.class
> 
> Below is the relevant piece of FO, I'm placing this in the xsl-region-body:
> 
> <fo:block span="all" space-after="1em"/>
> <fo:block white-space-treatment="preserve" white-space-collapse="false"
> text-align="center" margin-left="0.833333in" margin-right="0.833333in"
> span="all" font-family="Times" font-size="10pt" color="#000000"
> font-weight="normal" font-style="normal" text-decoration="no-underline
> no-line-through" >
> <fo:external-graphic src="file:D:\workspace\fofiles\apolloImage_5.png"/>
> </fo:block>
> <fo:block span="all" />
> 
> Am I missing something that is preventing me from being able to get PNG
> images?
> 
> Thank you for any help you can provide.


Jeremias Maerki


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message