xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremias Maerki <...@jeremias-maerki.ch>
Subject Re: upgrading from 20.0.5 to the trunk
Date Mon, 12 Sep 2005 09:57:52 GMT
Sorry, Sonja, but a lot of changes have happened during the redesign
which break API compatibility. The packages and classes you listed don't
exist anymore. And the new API has not been documented, yet. This will
be done in the next two weeks and before the first preview release. In
the meantime, you can look at the embedding examples in
examples/embedding on how to embed FOP Trunk in a Java application.

If you prefer an API that works on both FOP 0.20.5 and FOP Trunk, I have
started a solution at http://www.jeremias-maerki.ch/dev/jaxg/index.html.
But either way, you will have to change your application once.

Also needless to say that FOP Trunk is unstable (alpha) as will be the
first preview release.

On 12.09.2005 11:40:50 Sonja Löhr wrote:
> Hi!
> 
> After inspecting the new compliance page (:-)) great improvements!!), I
> finally downloaded the trunk and built it.
> Now my servlet code is missing several packages/classes :
> org.apache.fop.messaging
> org.apache.fop.configuration
> and classes in org.apache.fop.apps (Driver and Options)
> 
> Did I miss some sources or where can I find documentation about a new
> way of programmatic configuration, logging and Servlet integration?
> Sorry, I'm a bit lost in the developer's section of the fop site.
> 
> Thank you for some hints,
> I would love to use the new features!
> 
> sonja


Jeremias Maerki


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message