xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Greg Stark" <gst...@electrorent.com>
Subject Invalid XML character (Unicode: 0x0)
Date Fri, 09 Sep 2005 23:10:53 GMT
fop-users,
How can I resolve this?  Is there a way on Solaris to search and replace
0000x0 characters.  This is an XSLT question, I am asking here because it is
part of my FOP process before the file is translated to fo and then a PDF.  

The file saved as UTF-8 contains Chinese characters.  I go to that location,
and there is no null character there!  I can replace spaces before the
location with &#160; and this seems to move the message to a new location.
No pattern has emerged yet.

/usr/local/FOP/xalan.sh -v
>>>>>>> Xalan Version Xalan Java 2.2.D11, <<<<<<<

/usr/local/FOP/xalan.sh -in maporder2153450ZHSS.xml -XSL ZHrsShip_data.xsl
-out tmp2.xml
[Fatal Error] ZHrsShip_data.xsl:420:95: An invalid XML character (Unicode:
0x0) was found in the element content of the document.
file:///XMLFOP/rsship/ZHrsShip_data.xsl; Line 420; Column 95; XSLT Error
(javax.xml.transform.TransformerConfigurationException):
javax.xml.transform.TransformerException: org.xml.sax.SAXParseException: An
invalid XML character (Unicode: 0x0) was found in the element content of the
document.

  ZHrsShip_data.xsl file available on request.

I appreciate your time and help.
Thank you very much.

Greg Stark <gstark at electrorent dot com>



---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message